phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Firas Khasawneh <Firas.Khasaw...@sas.com>
Subject RE: tables are not showing in HBase & joins are not working
Date Tue, 18 Mar 2014 18:44:11 GMT
Hi Alex,

Phoenix 2.2.3

HBase 0.94.12 (Bigtop 0.7.0)

I am able to create tables, scan, etc in HBase

I am not getting any errors in hbase logs. Below are the create tables statements:

create table address(pid BIGINT not null primary key, personaddress varchar(100));
create table person(pid BIGINT not null primary key, firstname varchar(100), lastname varchar(100));

I am getting the following error when I run the query below:

select a.firstname, a.lastname, b.personaddress from person AS a INNER JOIN address AS b ON
a.pid = b.pid


Error:

Error: ERROR 602 (42P00): Syntax error. Missing "EOF" at line 1, column 66. (state=42P00,code=602)


From: alex kamil [mailto:alex.kamil@gmail.com]
Sent: Tuesday, March 18, 2014 2:36 PM
To: user@phoenix.incubator.apache.org
Subject: Re: tables are not showing in HBase & joins are not working

Firas, this is strange,
do you see errors in hbase logs?
what hbase and phoenix versions are you using?
if you create tables in hbase  directly (via hbase shell) do you see them?
are there any special characters, quotes in table names?

Alex


On Tue, Mar 18, 2014 at 12:51 PM, Firas Khasawneh <Firas.Khasawneh@sas.com<mailto:Firas.Khasawneh@sas.com>>
wrote:
Hi,

I downloaded and installed Phoenix. I able to connect to HBase and create tables but I am
facing two issues:

  *   I am not able to see the tables in HBase. When I run scan 'tablename', I get table does
not exist
  *   I am not able to query on two tables using equi inner joins
Any help is appreciated.

Regards,
Firas



Mime
View raw message