phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Taylor <jamestay...@apache.org>
Subject Re: No tables shown after updating to 2.2.3
Date Thu, 13 Feb 2014 17:40:16 GMT
So the NPE happens when you start sqlline? There's nothing Phoenix-related
on the stack.

Can you send me the output from a scan over your SYSTEM.TABLE from the
HBase shell?




On Thu, Feb 13, 2014 at 9:30 AM, Justin Workman <justinjworkman@gmail.com>wrote:

> Connected to: Phoenix (version 2.2)
> Driver: org.apache.phoenix.jdbc.PhoenixDriver (version 2.2)
> Autocommit status: true
> Transaction isolation: TRANSACTION_READ_COMMITTED
> Building list of tables and columns for tab-completion (set fastconnect to
> true to skip)...
> 210/210 (100%) Done
> Done
> java.lang.NullPointerException
> at java.util.TreeMap.put(TreeMap.java:556)
>  at java.util.TreeSet.add(TreeSet.java:255)
> at sqlline.SqlLine$SQLLineSQLCompletor.<init>(SqlLine.java:4434)
>  at sqlline.SqlLine$DatabaseConnection.setCompletions(SqlLine.java:4574)
> at sqlline.SqlLine$DatabaseConnection.access$700(SqlLine.java:4508)
>  at sqlline.SqlLine.setCompletions(SqlLine.java:1814)
> at sqlline.SqlLine.access$2500(SqlLine.java:56)
> at sqlline.SqlLine$Commands.connect(SqlLine.java:3944)
>  at sqlline.SqlLine$Commands.connect(SqlLine.java:3851)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>  at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
>  at java.lang.reflect.Method.invoke(Method.java:606)
> at sqlline.SqlLine$ReflectiveCommandHandler.execute(SqlLine.java:2810)
>  at sqlline.SqlLine.dispatch(SqlLine.java:817)
> at sqlline.SqlLine.initArgs(SqlLine.java:633)
> at sqlline.SqlLine.begin(SqlLine.java:680)
>  at sqlline.SqlLine.mainWithInputRedirection(SqlLine.java:441)
> at sqlline.SqlLine.main(SqlLine.java:424)
> java.lang.NullPointerException
> at java.util.Properties$LineReader.readLine(Properties.java:434)
> at java.util.Properties.load0(Properties.java:353)
>  at java.util.Properties.load(Properties.java:341)
> at sqlline.SqlLine.getApplicationTitle(SqlLine.java:364)
>  at sqlline.SqlLine.begin(SqlLine.java:686)
> at sqlline.SqlLine.mainWithInputRedirection(SqlLine.java:441)
>  at sqlline.SqlLine.main(SqlLine.java:424)
> 0: jdbc:phoenix:name01.hadoop.test.overstock.> !tables
>
> +------------+-------------+------------+------------+------------+------------+---------------------------+----------------+-------------+----------------+
> | TABLE_CAT  | TABLE_SCHEM | TABLE_NAME | TABLE_TYPE |  REMARKS   |
> TYPE_NAME  | SELF_REFERENCING_COL_NAME | REF_GENERATION | INDEX_STATE |
> IMMUTABLE_ROWS |
>
> +------------+-------------+------------+------------+------------+------------+---------------------------+----------------+-------------+----------------+
>
> +------------+-------------+------------+------------+------------+------------+---------------------------+----------------+-------------+----------------+
> 0: jdbc:phoenix:name01.hadoop.test.overstock.> !quit
>
>
>
> On Thu, Feb 13, 2014 at 10:19 AM, James Taylor <jamestaylor@apache.org>wrote:
>
>> Can you send me the NPE you get on startup?
>>
>> On first connection to the cluster, Phoenix will do the following:
>> 1) switch coprocessors on SYSTEM.TABLE to the new org.apache ones
>> 2) scan your SYSTEM.TABLE for any existing tables and switch coprocessors
>> on them too
>>
>> Looks like something went wrong between (1) and (2).
>>
>> Thanks,
>> James
>>
>>
>>
>> On Thu, Feb 13, 2014 at 8:55 AM, Justin Workman <justinjworkman@gmail.com
>> > wrote:
>>
>>> I updated phoenix in my test cluster today from 2.2.2 to 2.2.3. Every
>>> thing starts fine, however I when running sqlline I get a Null Pointer
>>> exception on startup and no tables are show when issuing a !tables command.
>>>
>>> When looking at the tables in HBase shell, I can see that the
>>> coprocessor definitions on the SYSTEM.TABLE have been updated to
>>> org.apache.phoenix.XXX but none of the other tables were updated, and the
>>> SYSTEM.TABLE does not show up in sqlline shell either.
>>>
>>> Any pointers on how I would go about updating the coprocessors on these
>>> tables, and what I need to do to get the tables to show via sqlline. When I
>>> connect via sqlline this is the only thing I see in the master servers logs.
>>>
>>> 2014-02-13 09:47:40,946 INFO
>>> org.apache.phoenix.coprocessor.UngroupedAggregateRegionObserver: Starting
>>> ungrouped coprocessor scan
>>> {"timeRange":[0,7],"batch":-1,"startRow":"","stopRow":"","totalColumns":0,"cacheBlocks":true,"families":{"_0":[]},"maxVersions":1,"caching":1000}
>>> 2014-02-13 09:47:40,962 INFO
>>> org.apache.phoenix.coprocessor.UngroupedAggregateRegionObserver: Finished
>>> scanning 0 rows for ungrouped coprocessor scan
>>> {"timeRange":[0,7],"batch":-1,"startRow":"","stopRow":"","totalColumns":0,"cacheBlocks":true,"families":{"_0":[]},"maxVersions":1,"caching":1000}
>>>
>>>
>>
>

Mime
View raw message