openwhisk-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kei Sawada...@swd.cc>
Subject Re: About Ruby2.5 runtime support proposal(in relation to #3725)
Date Thu, 07 Jun 2018 02:37:55 GMT
> > If you had time to write up generic instructions for creating a new
> > runtime, based on your experiences, it would help others add more. It has
> > been something we've been meaning to do since the PHP runtime.
> >
> > Also, if you get time, adding a simple OpenWhisk Ruby client library to
> the
> > default runtime would be really useful from a "developer" experience POV.
> > Just making it easy for developers to invoke functions & triggers from
> the
> > runtime would be 80% of the methods needed.
>

Yes if this PR goes well, I'm willing to do/consider both. Thanks for your
insight.


> diff --git a/ansible/files/runtimes.json b/ansible/files/runtimes.json
> index 44cb30f2..96a65001 100644
> --- a/ansible/files/runtimes.json
> +++ b/ansible/files/runtimes.json
> @@ -109,6 +109,17 @@
>                      "name": "action-php-v7.1"
>                  }
>              }
> +        ],
> +        "ruby": [
> +            {
> +                "kind": "ruby:2.5",
> +                "default": true,
> +                "deprecated": false,
> +                "image": {
> +                    "prefix": "remore",
> +                    "name": "openwhisk-runtime-ruby"
> +                }
> +            }
>          ]
>

Thank you for the better instruction. Definitely this looks nicer.

Best,
Kei

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message