openwhisk-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Sanda <jsa...@redhat.com>
Subject docker client API version used by invoker
Date Thu, 17 Aug 2017 22:23:51 GMT
I am trying set up OpenWhisk using https://github.com/
apache/incubator-openwhisk-deploy-kube. I ran into a problem with the
invoker. It is stuck in a crash loop with this message:

[ERROR] [#sid_101] [ContainerUtils] stdout:  stderr: /usr/bin/docker: Error
response from daemon: client is newer than server (client API version:
1.24, server API version: 1.22). See '/usr/bin/docker run --help'.
[marker:invoker_docker.run_error:29093:13]

The docker API version on my machine is 1.22. Is there a way I can change
the version of the docker client API that the invoker uses? I have been
looking in the gradle scripts but have not found anything yet.

Thanks

John

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message