ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fátima Castro Jul <fat...@det.uvigo.es>
Subject Re: Examples are not working
Date Thu, 25 Jan 2018 11:44:43 GMT
Thanks for your help!

Now, the processes are displayed in the web interface. However, the 
ode.log file is still not created and I get the same error when I try to 
call the deployed processes:

|bin/sendsoap http://localhost:8080/ode/processes/helloWorld 
testRequest.soap|

|Error: Could not find or load main class 
org.apache.ode.tools.sendsoap.cline.Http|

Where should I place the bin folder that contains the calls for processes?


On 25/01/18 10:00, Sathwik B P wrote:
> There is no problem in the setup. May be just before process deployment was
> to begin you might have stopped the server.
>
> I could get the processes deployed and its displaying in the web interface.
>
> 1) Shutdown tomcat
> 2) delete *.deployed files under /ode/WEB-INF/processes
> 3) Edit tomcat/webapps/ode/WEB-INF/classes/log4j.xml
> append="false" => when the tomcat is stopped the log file will be cleared.
> Make it true. You should be able to see the ode.log file under tomcat/bin.
> If you want to a different location for the log file then provide the full
> path for the fileName attibute shown down.
>
> REPLACE this line
> <File name="FILE" fileName="ode.log" append="false">
> WITH
> <File name="FILE" fileName="ode.log" append="true">
>
> 4) Start tomcat and check in the web interface
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message