ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fátima Castro Jul <fat...@det.uvigo.es>
Subject Examples are not working
Date Mon, 22 Jan 2018 16:54:10 GMT
Hi,

I have tried to install Apache Ode and run the examples but I have not 
been able to make them work. I am using ODE 1.3.7, tomcat8 and Ubuntu 17.10.

For the installation procedure, I have followed the instructions for war 
deployment (http://ode.apache.org/war-deployment.html) but I am not sure 
if I got them right.

First, I have downloaded apache-ode-war-1.3.7.zip and extracted it. Then 
I have copied the ode.war file in this folder to the Tomcat's webapp 
directory, in my case it is //var/lib/tomcat8/webapps/. I have restarted 
Tomcat and ode was extracted.  Then, I have placed the examples in  the 
//var/lib/tomcat/webapps/ode/WEB-INF/processes/ folder/. /The ODE main 
page loads (http://localhost:8080/ode/#/) but does not recognize any 
service or process.  How should I know if the examples are successfully 
deployed?  The/ode.log/ file is never created.

I have checked Tomcat's log but it is not helping me. I normally get the 
following in /catalina.log/ when restarting:

|18-Jan-2018 16:23:51.645 INFO [localhost-startStop-1] 
org.apache.catalina.startup.HostConfig.deployDirectory Deploying web 
application directory [/var/lib/tomcat8/webapps/ode]||18-Jan-2018 16:23:54.631 INFO [localhost-startStop-1]

org.apache.catalina.startup.HostConfig.deployDirectory Deployment of web 
application directory [/var/lib/tomcat8/webapps/ode] has finished in 
[2,985] ms|

However,  sometimes I get this:

|19-Jan-2018 10:38:43.972 WARNING [localhost-startStop-2] 
org.apache.catalina.loader.WebappClassLoaderBase.clearReferencesJdbc The 
web application [ode] registered the JDBC driver 
[org.apache.derby.jdbc.AutoloadedDriver] but failed to unregister it 
when the web application was stopped. To prevent a memory leak, the JDBC 
Driver has been forcibly unregistered. 19-Jan-2018 10:38:43.973 WARNING 
[localhost-startStop-2] 
org.apache.catalina.loader.WebappClassLoaderBase.clearReferencesThreads 
The web application [ode] appears to have started a thread named 
[Timer-1] but has failed to stop it. This is very likely to create a 
memory leak. Stack trace of thread: java.lang.Object.wait(Native Method) 
java.util.TimerThread.mainLoop(Timer.java:552) 
java.util.TimerThread.run(Timer.java:505) 19-Jan-2018 10:38:43.973 
SEVERE [localhost-startStop-2] 
org.apache.catalina.loader.WebappClassLoaderBase.checkThreadLocalMapForLeaks 
The web application [ode] created a ThreadLocal with key of type 
[java.lang.ThreadLocal] (value [java.lang.ThreadLocal@409a18d]) and a 
value of type [org.apache.derby.iapi.services.context.ContextManager] 
(value [org.apache.derby.iapi.services.context.ContextManager@33b194b]) 
but failed to remove it when the web application was stopped. Threads 
are going to be renewed over time to try and avoid a probable memory 
leak. 19-Jan-2018 10:38:45.302 INFO [localhost-startStop-1] 
org.apache.catalina.startup.HostConfig.deployWAR Deploying web 
application archive [/var/lib/tomcat8/webapps/ode.war] 19-Jan-2018 
10:38:56.788 INFO [localhost-startStop-1] 
org.apache.catalina.startup.HostConfig.deployWAR Deployment of web 
application archive [/var/lib/tomcat8/webapps/ode.war] has finished in 
[11,485] ms |

Either way, I get the same result.

When I try to call the examples following the instructions in the readme 
file:

|sendsoap http://localhost:8080/ode/processes/helloWorld testRequest.soap |

I get the error:

|Error: Could not find or load main class 
org.apache.ode.tools.sendsoap.cline.Http|

I am not sure where the bin folder should be placed but I have tried 
different locations without success.

I am new to ODE and I really lost on what to do to make this work.

Thanks in advance,

Fátima

||


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message