ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sathwik B P <sathwik...@gmail.com>
Subject Re: Move towards binary compatibility to JDK 1.6 or JDK 1.7 for 1.3.7 RELEASE
Date Sat, 28 Nov 2015 10:19:23 GMT
Pierre,

Trunk is already tagged as 1.4. It is already compilable on jdk 8. We need
to test it a bit more.

We need to bring adopters in sync with the trunk as soon as possible and
this is the first step to sync release branch and trunk.
On Nov 28, 2015 3:34 PM, "Pierre Smits" <pierre.smits@gmail.com> wrote:

> May I suggest (given the ODE-1.3.x branch not being jdk 8 compatible) to
> leave branch 1.3.x as is, and create a new branch (1.4?) to have that
> become fully jdk 8 compatible.... Both code and annotation wise.
>
> That would help sending a clear message to both community and potential
> adopters.
>
> Best regards,
>
>
> Pierre Smits
>
> *OFBiz Extensions Marketplace*
> http://oem.ofbizci.net/oci-2/
>
> On Sat, Nov 28, 2015 at 10:52 AM, Sathwik B P <sathwik.bp@gmail.com>
> wrote:
>
> > Hi pierre,
> > I am doing good. Thank you.
> > How's business process discussion going on. If you need us let us know.
> >
> > Moving to higher jdk has been sitting from long time. The reason i have
> > brought this issue is because of the use of legacy Annotations Api which
> > has been removed in jdk 8.
> >
> > ODE source code current release branch ODE-1.3.x is non compilable on jdk
> > 8.
> >
> > The new Annotation Api is available in jdk 1.6,1.7
> >
> > TRUNK branch is compilable on jdk 8 as as we have a completly new Jacob
> > implementation.
> >
> > I would prefer jdk 8 as the baselining for 1.3.7 release. Will wait for
> > responses from the commmunity
> > On Nov 28, 2015 4:49 AM, "Tammo van Lessen" <tvanlessen@gmail.com>
> wrote:
> >
> > > +1 for moving to JDK 7 (although its also already EOL), so JDK 8 would
> > also
> > > be an option if nobody objects.
> > >
> > > On Fri, Nov 27, 2015 at 7:57 AM, Sathwik B P <sathwik.bp@gmail.com>
> > wrote:
> > >
> > > > Hi All,
> > > >
> > > > This is a proposal to move towards minimum compliance to JDK 1.6 or
> 1.7
> > > > from existing JDK 1.5 for ODE 1.3.7 RELEASE.
> > > >
> > > > Is there anyone still on JDK 5 or 6? Let us know if there are any
> > > concerns.
> > > >
> > > > regards,
> > > > sathwik
> > > >
> > >
> > >
> > >
> > > --
> > > Tammo van Lessen - http://www.taval.de
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message