ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kesten <solarmobiletrail...@gmail.com>
Subject Re: tomcat-juli.jar missing
Date Sat, 16 Feb 2013 21:27:45 GMT


Tammo van Lessen wrote:
> 
> I'd suggest to
> approach the Eclipse BPEL team on their mailinglist.
> 

Thanks for the advice.  I found the bpel sourceforge forum and that linked
to another google group forum for bpel
https://groups.google.com/forum/?fromgroups=#!forum/bpelundereclipse

Where I discovered the fix to the tomcat-jli.jar missing problem
http://www-inf.it-sudparis.eu/~nguyen_n/teaching_assistant/bpel/installing_bpel_designer_and_apache_ode_on_eclipse

The link above covers both installation of ODE and BPEL designer.  Might be
worth adding to the official homepages of each project.

cheers,

kesten

ps.  etiquette instructions didn't say to keep or delete the untrimmed
message.  Keeping for this post.

--------------------


Hi Kesten,

Apache ODE and Eclipse BPEL are two different things. The former is a BPEL
runtime component whereas Eclipse BPEL is the graphical modeller. Although
Eclipse BPEL provides runtime support for Apache ODE, it looks like you're
experiencing troubles with the Eclipse BPEL part, so I'd suggest to
approach the Eclipse BPEL team on their mailinglist.

Thanks,
  Tammo


On Sat, Feb 16, 2013 at 2:42 AM, kesten
<solarmobiletrailers@gmail.com>wrote:

>
> Hello,
>
> I installed apache ode using http://download.eclipse.org/bpel/site/
>
> I get an error which appears not to be a showstopper regarding svn
> Subclipse talks to Subversion via a Java API that requires access to
> native
> libraries. Those libraries were either not found or an incompatible
> version
> was loaded. The errors are displayed velow. Information on getting a
> proper
> version installed and visible to Eclipse is available here:
> http://subclipse.tigris.org/wiki/JavaHL
>
> Perhaps this should be downgraded to a warning if it's not an essential
> dependency.
>
> even though i do have the libs installed.  Not sure where to go to fix the
> path so it's found.
> ----------
>
> I had several problems due to the fact that port 8080 is used by lots of
> programs and was occupied preventing installation.
>
> Once that was figured out, I had more troubles.  It's a little confusing
> since HellowWorldBPEL_designerAndODE.pdf is one of the few documents on
> the
> main site, but it should be updated or removed.
> --------
> I'm now having a problem which appears to be a missing dependency in the
> bundle at /bpel/site/
>
> Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/juli/logging/LogFactory
>         at
> org.apache.catalina.startup.Bootstrap.<clinit>(Bootstrap.java:60)
> Caused by: java.lang.ClassNotFoundException:
> org.apache.juli.logging.LogFactory
>
> Not sure what the best method is to resolve this.  Where do i put it if i
> download it?
>
> All in all, it's been 2 days trying to get it installed.  I guess i'm just
> a
> little unlucky with my setup, and i really appreciate the fact that this
> is
> an open source project.  But if you're looking for broader acceptance i'd
> recommend a little tlc and qa for the on-boarding procedure.
>
> any suggestions on the LogFactory would be appreciated
>
> kesten
>
>
> Mac os mountain lion 10.8
> MacBook Pro
> tomcat 7
> jre 1.6
> --
> View this message in context:
> http://old.nabble.com/tomcat-juli.jar-missing-tp35029723p35029723.html
> Sent from the Apache Ode User mailing list archive at Nabble.com.
>
>


-- 
Tammo van Lessen - http://www.taval.de


-- 
View this message in context: http://old.nabble.com/tomcat-juli.jar-missing-tp35029723p35031810.html
Sent from the Apache Ode User mailing list archive at Nabble.com.


Mime
View raw message