ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ishara premadasa <idpremad...@gmail.com>
Subject Re: Issue with WS-Security consuming a secure service in ODE
Date Mon, 03 Oct 2011 06:58:32 GMT
Hi Jorge,
I created a secured web service using axis2 and could successfully invoke it
through ODE. It seems that this is an issue with your endpoint file
configuration. Please refer [1] to read how to configure endpoint properties
for ODE endpoint files.
According to that your .endpoint file must be corrected as;

alias.CustomerDetailService-ns=http://ws.wso2.org/dataservice
CustomerDetailService-ns.CustomerDetailService.ode.security.policy.file=UTOverTransport.xml

Edit the file and make sure all your password callback handler classes etc.
are stored in a jar inside ode/WEB-INF/lib directory. Hope that you will be
able to run the process fine now. I have also attached the edited endpoint
file here.

[1].
https://cwiki.apache.org/confluence/display/ODExSITE/Endpoint+Configuration

On Thu, Sep 29, 2011 at 4:27 PM, ishara premadasa <idpremadasa@gmail.com>wrote:

>
>
> On Thu, Sep 29, 2011 at 4:00 PM, Jorge Infante Osorio <jorgeio@uci.cu>wrote:
>
>> I send you the files in every message I send to the list. I don´t
>> understand
>> what happen.
>> I send you again only to your mailbox with a copy to the list.
>>
>> In this case I send a .zip and the another files. Let me know if you can
>> see
>> it.
>>
>
> Yes, i can see them fine now. Will look into it.
>
>>
>> Saludos,
>> Ing. Jorge Infante Osorio.
>> J´Dpto Soluciones SOA.
>> CDAE.
>> Fac. 5.
>> UCI.
>>
>> -----Mensaje original-----
>> De: ishara premadasa [mailto:idpremadasa@gmail.com]
>> Enviado el: jueves, 29 de septiembre de 2011 2:10
>> Para: user@ode.apache.org
>> Asunto: Re: Issue with WS-Security consuming a secure service in ODE
>>
>> Hi Jorge,
>> I will look into this and try to find a solution. But however i still
>> don't
>> see any attachment. Can you send it to this thread soon?
>>
>> On Wed, Sep 28, 2011 at 6:25 PM, Jorge Infante Osorio <jorgeio@uci.cu
>> >wrote:
>>
>> > Done.
>> >
>> > Saludos,
>> > Ing. Jorge Infante Osorio.
>> > J´Dpto Soluciones SOA.
>> > CDAE.
>> > Fac. 5.
>> > UCI.
>> >
>> >
>> > -----Mensaje original-----
>> > De: Waruna Ranasinghe [mailto:warunapww@gmail.com] Enviado el:
>> > miércoles, 28 de septiembre de 2011 8:11
>> > Para: user@ode.apache.org
>> > Asunto: Re: Issue with WS-Security consuming a secure service in ODE
>> >
>> > Hi Jorge,
>> >
>> > On 28 September 2011 17:07, Jorge Infante Osorio <jorgeio@uci.cu>
>> wrote:
>> >
>> > > Thanks for Help Waruna.
>> > > The files are attached.
>> > >
>> > I still cannot see your attachment. Can you zip them up and attach.
>> >
>> >
>> > >
>> > > In WSO2 BPS the .epr file it works. But with the .axis2 and
>> > > .endpoint
>> > not.
>> > >
>> > > BPS use ODE as the BPEL Engine.\
>> > >
>> > Yes, WSO2 BPS uses ODE.  But, WSO2 BPS has its own axis2 integration
>> layer.
>> > Therefore, the endpoint configuration is not the same as ODE.
>> >
>> >
>> > Thanks,
>> > Waruna
>> >
>> >
>> >
>> > >
>> > > Saludos,
>> > > Ing. Jorge Infante Osorio.
>> > > J´Dpto Soluciones SOA.
>> > > CDAE.
>> > > Fac. 5.
>> > > UCI.
>> > >
>> > >
>> > > -----Mensaje original-----
>> > > De: Waruna Ranasinghe [mailto:warunapww@gmail.com] Enviado el:
>> > > miércoles, 28 de septiembre de 2011 4:31
>> > > Para: user@ode.apache.org
>> > > Asunto: Re: Issue with WS-Security consuming a secure service in ODE
>> > >
>> > > Hi Jorge,
>> > >
>> > >
>> > > On 23 September 2011 18:07, Jorge Infante Osorio <jorgeio@uci.cu>
>> wrote:
>> > >
>> > > > Hi all.****
>> > > >
>> > > > I´m working with Apache ODE, Intalio and WSO2´s Business Process
>> > > > Server to implement some BPs.****
>> > > >
>> > > > ** **
>> > > >
>> > > > In a BP I need to consume a secure service implemented using Axis2
>> > > > + Rampart, so I follow the recommendation in
>> > > > https://cwiki.apache.org/confluence/display/ODExSITE/WS-Security+i
>> > > > n+ OD E in all it variants, but with no success.
>> > > >
>> > >  **
>> > > >
>> > > > This is the error I see:****
>> > > >
>> > > > ** **
>> > > >
>> > > > [2011-09-23 01:35:54,584]  WARN - PartnerService - Fault response:
>> > > > <?xml version="1.0" encoding="UTF-8"?>****
>> > > >
>> > > > <message><Fault><faultcode xmlns:soapenv="
>> > > > http://schemas.xmlsoap.org/soap/envelope/" xmlns:wsse="
>> > > > http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity
>> > > > -s
>> > > > ec
>> > > > ext-1.0.xsd
>> > > > ">****
>> > > >
>> > > > wsse:InvalidSecurity</faultcode><faultstring xmlns:soapenv="
>> > > > http://schemas.xmlsoap.org/soap/envelope/" xmlns:wsse="
>> > > > http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurit*
>> > > > **
>> > > > *
>> > > >
>> > > > y-secext-1.0.xsd">Missing wsse:Security header in
>> > > > request</faultstring></Fault></message>****
>> > > >
>> > > > [2011-09-23 01:35:54,615]  WARN - BpelProcess - Instance 27651 of
>> > > > {
>> > > > http://wso2.org/sample/rule}CustomerOrderService-40 has completed
>> > > > with
>> > > > fault: FaultData: [faultName={http://ws.ws****
>> > > >
>> > > > o2.org/dataservice}UnknownFault<http://o2.org/dataservice%7DUnknownFault>
>> > > > <http://o2.org/dataservice%7DUnknownFault>,
>> > > > faulType=null] @115****
>> > > >
>> > > > **
>> > > >
>> > > Looks like the rampart module has not got engaged.
>> > >
>> > >
>> > >
>> > >
>> > > > **
>> > > >
>> > > > I send you attach the two file, CustomerDetailService.endpoint and
>> > > > CustomerDetailService.axis2, that I used in the different
>> > configurations.
>> > > >
>> > > Attachment is missing!, can you re-attach?
>> > >
>> > > Thanks,
>> > > Waruna
>> > >
>> > >
>> > > > ****
>> > > >
>> > > > ** **
>> > > >
>> > > > I can consume the secure web service using a
>> > > > CustomerDetailService.epr file suggested by wso2, but I don´t know
>> > > > if this way is supported by ODE for example in Intalio. ****
>> > > >
>> > > > ** **
>> > > >
>> > > > Can any want help me on this?****
>> > > >
>> > > > ** **
>> > > >
>> > > > Saludos,****
>> > > >
>> > > > Ing. Jorge Infante Osorio.****
>> > > >
>> > > > J´Dpto Soluciones SOA.****
>> > > >
>> > > > CDAE.****
>> > > >
>> > > > Fac. 5.****
>> > > >
>> > > > UCI.****
>> > > >
>> > > > ** **
>> > > >
>> > >
>> > >
>> > >
>> > > --
>> > > -----------------------------------------------------
>> > > Regards,
>> > > Waruna Ranasinghe
>> > >
>> > > blog: http://warunapw.blogspot.com
>> > > twitter: http://twitter.com/warunapww
>> > > http://lk.linkedin.com/in/waruna www.facebook.com/waruna.ranasinghe
>> > >
>> >
>> >
>> >
>> > --
>> > -----------------------------------------------------
>> > Regards,
>> > Waruna Ranasinghe
>> >
>> > blog: http://warunapw.blogspot.com
>> > twitter: http://twitter.com/warunapww
>> > http://lk.linkedin.com/in/waruna
>> > www.facebook.com/waruna.ranasinghe
>> >
>>
>>
>>
>> --
>> *Best Regards.*
>>
>> *Ishara Premadasa,*
>> Trainee Software Engineer/Undergraduate, Dept. of Computer Science &
>> Engineering, University of Moratuwa Sri Lanka.
>> http://isharapremadasa.blogspot.com
>>
>
>
>
> --
> *Best Regards.*
>
> *Ishara Premadasa,*
> Trainee Software Engineer/Undergraduate,
> Dept. of Computer Science & Engineering,
> University of Moratuwa
> Sri Lanka.
> http://isharapremadasa.blogspot.com
>
>
>
>


-- 
*Best Regards.*

*Ishara Premadasa,*
Trainee Software Engineer/Undergraduate,
Dept. of Computer Science & Engineering,
University of Moratuwa
Sri Lanka.
http://isharapremadasa.blogspot.com

Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message