ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tammo van Lessen <tvanles...@gmail.com>
Subject Re: Trying to get ODE started
Date Fri, 09 Sep 2011 14:59:10 GMT
Hi,

did tomcat explode the war? There should be now an ode directory
within the webapps directory. If it is and it is nevertheless not
working, please have a look at tomcats log files, perhaps there are
some exceptions logged.

HTH,
  Tammo

On Sat, Jun 4, 2011 at 15:12, David Georg Reichelt
<davidgeorg_reichelt@yahoo.de> wrote:
> Hi,
>
> I am currently trying to start ODE and just run the examples, by doing what
> is described here http://ode.apache.org/war-deployment.html . As I am
> running ubuntu, tomcat was already installed, so I just put the .war File in
> the webapps directory (so /var/lib/tomcat6/webapps/). It also was already
> named ode.war (the text said, I should rename the .war File from the root
> directory and name it ode.war, but it was already called this way).
> Afterwards, I tryied running the testpage by viewing
> http://localhost:8080/ode through the browser, but it wasn't working (it
> says 404,*description* _The requested resource (/ode/) is not available.).
> _Unfortunately, the examples aren't working, too. I tried to copy them and
> then run them by calling "sendsoap", but it said:
>
> Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/ode/tools/sendsoap/cline/HttpSoapSender
> Caused by: java.lang.ClassNotFoundException:
> org.apache.ode.tools.sendsoap.cline.HttpSoapSender
>    at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
>    at java.security.AccessController.doPrivileged(Native Method)
>    at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
>    at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
>    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
>    at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
> Could not find the main class:
> org.apache.ode.tools.sendsoap.cline.HttpSoapSender. Program will exit.
>
> For this, I used the .war-file in version 1.3.5. I don't know, why ode isn't
> starting, does anyone know what I'm doing wrong?
>
> Best Regards,
> David
>



-- 
Tammo van Lessen - http://www.taval.de

Mime
View raw message