ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jorge Infante Osorio" <jorg...@uci.cu>
Subject Issue with WS-Security consuming a secure service in ODE
Date Fri, 23 Sep 2011 12:37:23 GMT
Hi all.

I´m working with Apache ODE, Intalio and WSO2´s Business Process Server to
implement some BPs.

 

In a BP I need to consume a secure service implemented using Axis2 +
Rampart, so I follow the recommendation in
https://cwiki.apache.org/confluence/display/ODExSITE/WS-Security+in+ODE in
all it variants, but with no success. 

 

This is the error I see:

 

[2011-09-23 01:35:54,584]  WARN - PartnerService - Fault response: <?xml
version="1.0" encoding="UTF-8"?>

<message><Fault><faultcode
xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:wsse="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecuri
ty-secext-1.0.xsd">

wsse:InvalidSecurity</faultcode><faultstring
xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:wsse="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecuri
t

y-secext-1.0.xsd">Missing wsse:Security header in
request</faultstring></Fault></message>

[2011-09-23 01:35:54,615]  WARN - BpelProcess - Instance 27651 of
{http://wso2.org/sample/rule}CustomerOrderService-40 has completed with
fault: FaultData: [faultName={http://ws.ws

o2.org/dataservice}UnknownFault, faulType=null] @115

 

I send you attach the two file, CustomerDetailService.endpoint and
CustomerDetailService.axis2, that I used in the different configurations.

 

I can consume the secure web service using a CustomerDetailService.epr file
suggested by wso2, but I don´t know if this way is supported by ODE for
example in Intalio. 

 

Can any want help me on this?

 

Saludos,

Ing. Jorge Infante Osorio.

J´Dpto Soluciones SOA.

CDAE.

Fac. 5.

UCI.

 


Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message