ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sebastian Luft <sebastian.l...@gmail.com>
Subject Re: ODE compilation problems
Date Tue, 14 Dec 2010 12:05:01 GMT
Hi Tammo,

even if your solution is not the one that solved the issue, it still
pointed me to what went wrong: "$ buildr artifacts" gave me some
permission denied errors and aborted, then I looked at the repository
and found out all files were created by root and the current user
could not read them, thats why eclipse didn't find them. I started
over, deleted the .m2 folder and issued "$ buildr package" without
sudo in front of it. Now all went good and after "$ buildr eclipse"
and importing the projects, there were "only" 52 errors left.
Majority came from project "ode-jacob-ap", where the package
"com.sun.mirror" was missing. I downloaded this jar file
http://www.findjar.com/jar/org/eclipse/jdt/apt/core/3.3.0-v20070607-1200/core-3.3.0-v20070607-1200.jar.html
and manually added it to the build path of "ode-jacob-ap" and had only
12 errors left.
Most of them came from the project "ode-axis2-war" from one single
class in package "org.apache.ode.axis2.correlation" named
"CorrelationUnicityTest". After assigning the eclipse quickfix which
moved that class to the package "org.apache.ode.axis2", only two
errors remained.
To fix both of these, I removed the project "ode-bpel-scripts" form
the build path of project "ode-bpel-test" (which wasn't required
anyway) and then it all worked!

It's been a long way, but finally I got it working! Again, thank you
for your help.
Greetings, Sebastian.

On Mon, Dec 13, 2010 at 6:28 PM, Tammo van Lessen <tvanlessen@gmail.com> wrote:
> Hi Sebastian,
>
> usually buildr downloads all artifacts into your local m2 repository.
> Please verify if the are there or check why eclipse does not find them.
> Perhaps Eclipse needs to rebuild all projects.
>
> If the artifacts are not there already, please run "buildr artifacts"
> and then "buildr eclipse" again.
>
> HTH,
>  Tammo

Mime
View raw message