ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bala Subramaniam <bapa...@yahoo.co.uk>
Subject Re: Error while running the examples
Date Mon, 20 Dec 2010 13:44:01 GMT
I have been able to move forward and the samples are working.
I am now trying to work through the tutorial HelloWorld-BPELDesignerAndODE and 
facing some issue.
While editing the deploy.xml the 'Assign Port' drop down is empty. 
I am not sure where i am going wrong. Appreciate any help.
Regards




----- Original Message ----
From: Bala Subramaniam <bapajan@yahoo.co.uk>
To: user@ode.apache.org
Sent: Wed, 15 December, 2010 11:31:29
Subject: Re: Error while running the examples

As suggested, I tried the end point as given below and face an error. Grateful 
for any help.

http://localhost:8080/ode/processes/HelloWorld

or 
http://localhost:8080/ode/processes/HelloWorld2

both of the above end points results in the error

<Exception>
org.apache.axis2.AxisFault: The service cannot be found for the endpoint 
reference (EPR) /ode/processes/HelloWorld

    at 
org.apache.axis2.engine.DispatchPhase.checkPostConditions(DispatchPhase.java:62)

    at org.apache.axis2.engine.Phase.invoke(Phase.java:308)

    at org.apache.axis2.engine.AxisEngine.invoke(AxisEngine.java:212)

    at org.apache.axis2.engine.AxisEngine.receive(AxisEngine.java:132)

    at 
org.apache.axis2.transport.http.util.RESTUtil.invokeAxisEngine(RESTUtil.java:125)



    at 
org.apache.axis2.transport.http.util.RESTUtil.processURLRequest(RESTUtil.java:119)



    at 
org.apache.axis2.transport.http.AxisServlet$RestRequestProcessor.processURLRequest(AxisServlet.java:799)



    at org.apache.axis2.transport.http.AxisServlet.doGet(AxisServlet.java:242)

    at org.apache.ode.axis2.hooks.ODEAxisServlet.doGet(ODEAxisServlet.java:62)

    at javax.servlet.http.HttpServlet.service(HttpServlet.java:617)

    at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)

    at 
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)



    at 
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)



    at 
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)



    at 
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)



    at 
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)

    at 
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)

    at 
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)



    at 
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)

    at 
org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:861)

    at 
org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:579)



    at org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1584)

    at java.lang.Thread.run(Thread.java:619)

</Exception>



----- Original Message ----
From: Tammo van Lessen <tvanlessen@gmail.com>
To: user@ode.apache.org
Sent: Sat, 11 December, 2010 18:54:28
Subject: Re: Error while running the examples

Hi Bala,

I think you are running into
https://issues.apache.org/jira/browse/ODE-856 - this has been fixed
already for 1.3.5, which is close to be released. As a workaround, you
can take the endpoint information directly from the WSDLs in the
deployment bundle.

HTH,
  Tammo

On 11.12.2010 06:01, Bala Subramaniam wrote:
> Hi,
> 
> I followed the tutorial at 
> https://cwiki.apache.org/confluence/display/ODExSITE/WAR+Deployment
> I get the following error while trying to run the examples. The details are as 


> follows:
> I am getting the Apache ODE page and able to see the example processes but with 
>
>
> error message as stated below.
> 
> Error Message
> 
> Processes:
> Error occurred during getting processes or no processes.
> Contents:
> DynPartner\DynPartnerMain.bpel, DynPartner\DynPartnerResponder.bpel, 
> DynPartner\Main.wsdl, DynPartner\Responder.wsdl, 
> 
> 
> Am enclosing the log files too.
> 
> working Environment
> 
> Tomcat 6.x
> Mysql 5.1.39
> Windows 7
> Apache ODE 1.3.4
> 
> Appreciate your time and help in resolution of the issue.
> Regards
> 
> 
>      

-- 
Tammo van Lessen - http://www.taval.de


      

Mime
View raw message