ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tammo van Lessen <tvanles...@gmail.com>
Subject Re: new compilation of ode-bpel-runtime.jar archive from source with compilation error - eclipse
Date Mon, 29 Nov 2010 23:15:15 GMT
Hi Battal,

these classes are only needed during build time and not for runtime
execution. Hence, they are not included in the binary distribution. If
you download the source distribution or check out the 1.3.3 tag, the
files will be there.

HTH,
  Tammo

On 30.11.2010 00:11, Battal Kekec wrote:
> Hi developers, Hi users,
> 
> I get errors when I try to compile the whole ode-bpel-runtime.jar
> archive from source.
> My environment is in eclipse. I have made a new project in eclipse with
> the ode-bpel-runtime sources
> and loaded all the other jar libraries in this project from
> apache-ode-war-1.3.3. It is curious that I get
> errors like "The import org.apache.ode.jacob.ap cannot be resolved" in
> org.apache.ode.bpel.runtime.channels.ActivityRecovery.
> The jacop-ap jar file isn't deployed with apache-ode-war-1.3.3, but the
> jacop jar file is deployed. So the environment
> couldn't find the org.apache.ode.jacob.ap library.
> 
> Please help me for this issue.
> 
> 
> regards
> Battal Kekec

-- 
Tammo van Lessen - http://www.taval.de

Mime
View raw message