ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Blotny <Alexander.Blo...@fokus.fraunhofer.de>
Subject Copy Assignment
Date Thu, 05 Aug 2010 07:45:37 GMT
Hi,

I have a problem with initializing a variable for a request.
The following copy Assignment is made:

        <bpel:assign validate="no" name="GetTimeRequest">
<bpel:copy>                <bpel:from>                    <bpel:literal
xml:space="preserve"><impl:getTimeForNextCalendarTelcoEventEntry
xmlns:impl="http://mashup.service.see.xposer.ngni.fokus.fhg.de/">
<impl:arg0></impl:arg0>
</impl:getTimeForNextCalendarTelcoEventEntry></bpel:literal>
</bpel:from>                <bpel:to variable="GetTimeRequest"
part="getTimeForNextCalendarTelcoEventEntry"></bpel:to>
</bpel:copy>             <bpel:copy>                <bpel:from>
<bpel:literal xml:space="preserve">tonline.robert</bpel:literal>
</bpel:from>                <bpel:to
part="getTimeForNextCalendarTelcoEventEntry"
variable="GetTimeRequest">                    <bpel:query
queryLanguage="urn:oasis:names:tc:wsbpel:2.0:sublang:xpath1.0">
<![CDATA[ns2:arg0]]>                    </bpel:query>
</bpel:to>            </bpel:copy>
        </bpel:assign>


The request send by Ode looks that way:

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
<soapenv:Body>
    <getTimeForNextCalendarTelcoEventEntry
xmlns="http://mashup.service.see.xposer.ngni.fokus.fhg.de/">
        <impl:arg0 
xmlns:impl="http://mashup.service.see.xposer.ngni.fokus.fhg.de/">test</impl:
arg0>
     </getTimeForNextCalendarTelcoEventEntry>
</soapenv:Body>
</soapenv:Envelope>

This is not working properly as the value of arg0 is only null in the called
service method.
With SoapUI following request works:

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
...
   <soapenv:Body>
    <mas:getTimeForNextCalendarTelcoEventEntry
xmlns:mas="http://mashup.service.see.xposer.ngni.fokus.fhg.de/">
        <arg0>test</arg0>
    </mas:getTimeForNextCalendarTelcoEventEntry>
   </soapenv:Body>
</soapenv:Envelope>

I tried a lot of modifications in the copy tag but most of the time it
resulted in a selectionFailure.
What can I change to get a valid request for my Web Service?

greetings,
Alex


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message