ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Boisvert <boisv...@intalio.com>
Subject Re: ODE Performance
Date Tue, 22 Sep 2009 23:23:41 GMT
Events are not persisted for in-memory processes so there's no need to
configure event filtering.

alex

On Mon, Sep 21, 2009 at 11:49 PM, Daniel Maier <mail@daniel-maier.eu> wrote:

>
> Hi Alex,
>
> thank you very much for the advice with the events. I didn't see this
> before :/. This hint brought us a big performance boost.
> Does this have also an effect if i run the process in memory mode?
>
> Thanks a lot
>
> Daniel
>
> On Mon, 21 Sep 2009 14:33:13 -0700, Alex Boisvert <boisvert@intalio.com>
> wrote:
> > Hi Daniel,
> >
> > Two minutes for invoking 2-3 services seems like a LOOOOOOONG time --
> such
> > process should execute in a few seconds if the services respond
> > immediately.
> >
> > I would try the following:
> >
> > 1) monitor CPU / IO / memory usage -- is there bottleneck?  (if any)
> > 2) turn on debug logging for Ode in general and see what's happening
> > 3) Ode is very persistence-heavy so I would check the database layer to
> see
> > what's happening there as well.
> >
> > The first thing I generally suggest to improve performance is to
> > selectively
> > disable event
> >
> persistence<
> http://ode.apache.org/user-guide.html#UserGuide-Filteringevents>.
> >
> >
> > Good luck,
> > alex
> >
> > On Sun, Sep 20, 2009 at 5:18 AM, Daniel Maier <mail@daniel-maier.eu>
> wrote:
> >
> >> Dear ODE Dev. Team,
> >> recently I installed Apache ODE 1.3.3 on my Server.
> >> First of all i want to thank for the great work you have done so far :)
> >>
> >> My question:
> >> I have deployed approximately 10 processes in my ODE installation.
> >> But now i ran into some performance issuses.
> >>
> >> A process which invokes 2-3 WebServices needs a lot of time (up to 2
> >> minutes).
> >> If I invoke each process directly via a WebService testing tool, i got
> an
> >> immediate response.
> >> Therefore i think that the single services are not the bottle neck.
> >>
> >> Perhabs there is just some sort of debug-mode still enabled?
> >> What kind of hardware (CPU/RAM) do you recommend?
> >> I hope you can give me some hint, how i can speed up ODE a little :)
> >>
> >>
> >> My system onfiguration:
> >> * ODE is using MySQL
> >> * ODE is running under Tomcat 6
> >> * Tomcat is using Java6
> >>
> >>
> >> Thanks in advance and keep rocking :)
> >>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message