ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul.John...@metavante.com
Subject Re: xsd-complex-type-wrapper
Date Thu, 06 Aug 2009 19:26:35 GMT
More Information....

I also tried in in the beta 2 release, and I am getting the same results.

Thanks,

Paul


                                                                                         
    
  From:       Paul.Johnson@metavante.com                                                 
    
                                                                                         
    
  To:         user@ode.apache.org                                                        
    
                                                                                         
    
  Date:       08/06/2009 01:38 PM                                                        
    
                                                                                         
    
  Subject:    xsd-complex-type-wrapper                                                   
    
                                                                                         
    






Hello all,

I am using ODE 1.3.2  on Tomcat 6.0.20

I am getting this back from my bpel call:

<xsd-complex-type-wrapper>
      <typ xmlns="http://www.metavante.com/mvnt_InvolvedParty">House
Number</typ>
      <val xmlns="http://www.metavante.com/mvnt_InvolvedParty">845 W.
Hampton Ave</val>
</xsd-complex-type-wrapper>

The variable is defined as the following:

<bpel:variable name:="addrCmpt" type="ns3:PstlAddrCmpt"></bpel:variable>

I am initializing the variable with the following code
<bpel:literal xml:space="preserve">
    <mvnt_InvolvedParty:PstlAddrCmpt
            xmlns:mvnt="http://www.metavante.com/mvnt"
            xmlns:mvnt_Common="http://www.metavante.com/mvnt_Common"

xmlns:mvnt_InvolvedParty="http://www.metavante.com/mvnt_InvolvedParty"
            xmlns:p="mvntCommon" xmlns:p1="mvntCommonRqstHdr"
xmlns:p2="mvntCommonRspHdr"
            xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <mvnt_InvolvedParty:typ></mvnt_InvolvedParty:typ>
            <mvnt_InvolvedParty:val></mvnt_InvolvedParty:val>
      </mvnt_InvolvedParty:PstlAddrCmpt>
</bpel:literal>

I an inserting the object into a list using the following:

<bpel:copy keepSrcElementName="yes">
    <bpel:from>
        <![CDATA[ode:insert-as-first-into($addrOsi, $addrCmpt)]]>
    </bpel:from><bpel:to>
        <![CDATA[$addrOsi]]>
    </bpel:to>
</bpel:copy>

I have not had this problem before, so I am completely baffled.  Any help
would be great.

Paul R. Johnson

---------------------------------------------------------------------
This message contains confidential and proprietary information of the
sender, and is intended only for the person(s) to whom it is addressed.
Any use, distribution, copying or disclosure by any other person is
strictly prohibited.  If you have received this message in error, please
notify the e-mail sender immediately, and delete the original message
without making a copy.




---------------------------------------------------------------------
This message contains confidential and proprietary information of the
sender, and is intended only for the person(s) to whom it is addressed.
Any use, distribution, copying or disclosure by any other person is
strictly prohibited.  If you have received this message in error, please
notify the e-mail sender immediately, and delete the original message
without making a copy.


Mime
View raw message