ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From buddhika chamith <chamibuddh...@gmail.com>
Subject Re: Problem With XPath expressions
Date Thu, 06 Aug 2009 04:52:46 GMT
Hi Wenfeng,

Thanks for the quick reply. I tried out your suggestion. Changed Assign as

 <assign>
      <copy>
          <from
expression="fn:concat(bpws:getVariableData('probeInput','probeData'),bpws:getVariableData('probeInput','probeName'))"/>
         <to variable="probeInput" part="probeData"/>
      </copy>
 </assign>

with <xmlns:fn="http://www.w3.org/2005/02/xpath-functions">

But unfortunately it didn't solve the problem. Still giving that error.
Anyway I have attached modified BPEL as well. Any more ideas as to how to
make this work?

Regards,
Chamith




On Thu, Aug 6, 2009 at 6:19 AM, Wenfeng ZHAO <zhaowenfeng@gmail.com> wrote:

> It seems XPath 2.0 requires that functions, such as concat(), be qualified
> by namespace prefixes. And the version of XPath you use is just 2.0, rather
> than 1.0 :(
>
>
> Regards,
> Wenfeng
>
> 2009/8/5 buddhika chamith <chamibuddhika@gmail.com>
>
> > Hi all,
> >
> > I am having trouble deploying a BPEL process because there are some
> errors
> > reported by BPEL compiler.
> > The exception is as follows.
> >
> > java.lang.IllegalStateException: XPath string and xpath node are both
> null
> >     at
> >
> org.apache.ode.bpel.elang.xpath20.compiler.XPath20ExpressionCompilerImpl.doJaxpCompile(XPath20ExpressionCompilerImpl.java:129)
> >     at
> >
> org.apache.ode.bpel.elang.xpath20.compiler.XPath20ExpressionCompilerImpl._compile(XPath20ExpressionCompilerImpl.java:121)
> >     at
> >
> org.apache.ode.bpel.elang.xpath20.compiler.XPath20ExpressionCompilerImpl.compile(XPath20ExpressionCompilerImpl.java:103)
> >     at
> >
> org.apache.ode.bpel.compiler.BpelCompiler.compileExpr(BpelCompiler.java:558)
> >     at
> >
> org.apache.ode.bpel.compiler.BpelCompiler.compileExpr(BpelCompiler.java:543)
> >     at
> >
> org.apache.ode.bpel.compiler.AssignGenerator.compileFrom(AssignGenerator.java:188)
> >     at
> >
> org.apache.ode.bpel.compiler.AssignGenerator.compile(AssignGenerator.java:76)
> >     at
> > org.apache.ode.bpel.compiler.BpelCompiler$7.run(BpelCompiler.java:922)
> >     at
> > org.apache.ode.bpel.compiler.BpelCompiler.compile(BpelCompiler.java:1086)
> >     at
> >
> org.apache.ode.bpel.compiler.BpelCompiler.compileActivity(BpelCompiler.java:918)
> > ....
> >
> > There are several similar assign activities which I think may be the
> cause
> > of the problem.
> >         <assign>
> >             <copy>
> >                 <from
> >
> expression="concat(bpws:getVariableData('probeInput','probeData'),bpws:getVariableData('probeInput','probeName'))"/>
> >                 <to variable="probeInput" part="probeData"/>
> >             </copy>
> >         </assign>
> >
> > Variable definitions are as follows
> >
> >     <variables>
> >         <variable name="request" messageType="wns:requestMessage"/>
> >         <variable name="probeInput" messageType="wns:probeMessage"/>
> >         <variable name="reply" messageType="wns:replyMessage"/>
> >         <variable name="internalState"
> > messageType="wns:internalProcessData"/>
> >     </variables>
> >
> > Variable probeInput message definition
> >
> >     <wsdl:message name="probeMessage">
> >         <wsdl:part name="probeName" type="xsd:string" />
> >         <wsdl:part name="probeData" type="xsd:string" />
> >     </wsdl:message>
> >
> > I have checked for the correctness of the message element names etc. But
> > yet to find the reason for this behavior. Can some one please tell me
> what I
> > am doing wrong here? I have attached the BPEL process and the
> corresponding
> > wsdl file for your reference.
> >
> > Best Regards,
> > Chamith
> >
> >
>

Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message