ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bill McCusker <wmccus...@parasoft.com>
Subject Re: No ENTRY for RESPONSE CHANNEL
Date Mon, 03 Aug 2009 22:11:15 GMT
Hi Adiaz,

    I'll see if this reproduces for me.

Bill McCusker

adiaz.noriega@gmail.com wrote:
> Hi all,
>
> I'm facing an odd error while executing parallel activities:
>
> I have something like this:
> <flow>
> <sequence name="1">
> <assign name="set1">
> <invoke name="doActivity_1">
> <invoke name="doActivity_2">
> </sequence>
> <sequence name="2">
> <assign name="set2">
> <invoke name="doAnotherActivity_1">
> <invoke name="doAnotherActivity_2">
> </sequence>
> </flow>
>
> But, sometimes this error appear: INTERNAL ERROR: No ENTRY for 
> RESPONSE CHANNEL #
>
> what confused me is that when running the same process in memory, it 
> doesn't fail.
>
> This is my env:
> 1.- Apache 1.3.2
> 2.- ORACLE 9i
> 3.- JBoss 4.2.2 GA
>
> I have these parameters in ODE properties:
> **************************************
> ode-axis2.db.mode=EXTERNAL
> ode-axis2.db.ext.dataSource=java:jdbc/ODEDB
> ode-axis2.tx.factory.class=org.apache.ode.axis2.util.JBossFactory
> # Hibernate configuration
> hibernate.dialect=org.hibernate.dialect.Oracle9iDialect
> hibernate.show_sql=false
> hibernate.current_session_context_class=jta
> hibernate.transaction.manager_lookup_class=org.hibernate.transaction.JBossTransactionManagerLookup

>
> # Enable schema auto-generation.
> hibernate.hbm2ddl.auto = update
> #threads size
> ode-axis2.threads.pool.size=1
> *****************************************
>
> what do they mean about "no entry response channel"? and what do I am 
> doing wrong in my process" ???
>
> Any advice is very welcome
>
> Thanks in advance
>


Mime
View raw message