ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexis Midon <mi...@intalio.com>
Subject Re: Upgrading Axis2 on Ode1.3.2
Date Tue, 23 Jun 2009 16:33:54 GMT
ODE does depend on Axis2. ODE 1.3.2 uses axis2 1.3, ODE 2.0-beta on axis2
1.4.1.

You can find the corresponding dependencies in the Rakefile/Buildfile:
for the branch 1.X  ->
http://github.com/apache/ode/blob/APACHE_ODE_1.X/Rakefile#L33
for the trunk ->  http://github.com/apache/ode/blob/trunk/Buildfile#L46

The upgrade from 1.3 to 1.4.1 should be fairly straightforward. However I
don't think you can simply replace the jars. Off the top of head, I foresee
only a few changes in axis2.xml [1], an update of the axis2 modules
(ws-security, etc) and the corresponding test cases.

But it would make more sense to upgrade directly from 1.3 to the freshly
released 1.5.
You want to give it a try?

Alexis

[1]
http://github.com/apache/ode/blob/APACHE_ODE_1.X/axis2-war/src/main/webapp/WEB-INF/conf/axis2.xml

On Mon, Jun 22, 2009 at 8:46 PM, r r <shihoir@gmail.com> wrote:

> hello
> In Jira "Upgrade to Axis 1.4.1"(
> https://issues.apache.org/jira/browse/ODE-365),
> only rake files were changed for updating axis2,
> and it seems that ode-1.3.2 doesn't depend on versions of axis2.
>
> is it right?
> and then can I replace axis2-1.3 with another axis2
> version(axis2-1.4.1 or axis2-1.5)
> with Ode-1.3.2 ?
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message