ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexis Midon <mi...@intalio.com>
Subject Re: disable ws-addressing headers in sopa messages
Date Mon, 18 May 2009 19:17:07 GMT
Hi Hans-Peter,

obviously you're right. There's a typo in the property name [1]. Someone
drank to much caffeine that day...
consequently, you do need to type 3 'd's in your property files.
I filled an issue: ODE-607.

Sorry about that.

Alexis

[1]
http://svn.apache.org/viewvc/ode/branches/APACHE_ODE_1.X/utils/src/main/java/org/apache/ode/utils/Properties.java?revision=765012&pathrev=765012


2009/5/18 Hans-Peter Schmidt <chojinzero@mail.com>

> Hello,
> i want to disable ws-addressing in the soap messages generated by ode.
> I read that you have to create an *.endpoint file in your process
> directory and add the following line to disable ws-addressing:
> ws-adddressing.headers=false
> (only line in the file)
>
> Are the 3 'd' in adddressing correct? doesn't work with 2 'd' too.
> Filename is process.endpoint
> Location is \ode\WEB-INF\processes\myprocess
>
> So i did. Now even after restarting ode or waiting for over 30 seconds,
> the addressing content is still in the soap header.
>
> <soapenv:Header>
> <addr:To
> xmlns:addr="http://www.w3.org/2005/08/addressing">http://localhost:
> ...
>
> what do i do wrong?
>
> ODE Version = 1.3.2
> Tomcat Version = 6.0.18
>
> Thanks in advance.
>
> --
> Be Yourself @ mail.com!
> Choose From 200+ Email Addresses
> Get a Free Account at www.mail.com
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message