ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wenfeng ZHAO" <zhaowenf...@gmail.com>
Subject Re: Invoking external web service problem
Date Fri, 22 May 2009 01:25:45 GMT
Hello Ania,

I believe the problem isn't relative to BPEL or ODE, but in the component service. See the
following information you posted: 

>Here's a fragment from a server log:
>(...)
>DEBUG - GeronimoLog.debug(66) | Sending a message containing wsa 
>endpoints in headers for session passing.
>DEBUG - GeronimoLog.debug(66) | <?xml version='1.0' 
>encoding='utf-8'?><soapenv:Envelope 
>xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"><soapenv:Header><addr:To

>xmlns:addr="http://www.w3.org/2005/08/addressing">http://localhost:9090/HelloWS/HelloService</addr:To><addr:Action

>xmlns:addr="http://www.w3.org/2005/08/addressing"></addr:Action><addr:ReplyTo

>xmlns:addr="http://www.w3.org/2005/08/addressing"><addr:Address>http://www.w3.org/2005/08/addressing/anonymous</addr:Address></addr:ReplyTo><addr:MessageID

>xmlns:addr="http://www.w3.org/2005/08/addressing">uuid:hqejbhcnphr4ajmbcqe459</addr:MessageID></soapenv:Header><soapenv:Body><sayHello

>xmlns="http://hello.ania.org/">
><imie>Ania</imie></sayHello></soapenv:Body></soapenv:Envelope>
~~~~~~~~~~~~~~~~~~This is the input message generated by your BPEL process and targeted to
the component service.


>DEBUG - GeronimoLog.debug(66) | Service response:
><?xml version='1.0' encoding='utf-8'?><S:Envelope 
>xmlns:S="http://schemas.xmlsoap.org/soap/envelope/"><S:Body><ns2:sayHelloResponse

>xmlns:ns2="http://hello.ania.org/"><return>Hello, 
>null!</return></ns2:sayHelloResponse></S:Body></S:Envelope>
~~~~~~~~~~~~~~~This is the corresponding output message from the component service.  Note
"null!" appears in it.





= = = = = = = = = = = = = = = = = = = =
ZHAO Wenfeng
Ph.D. Candidate
http://www.bupt.edu.cn



Mime
View raw message