ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Luebke <daniel.lue...@inf.uni-hannover.de>
Subject Re: About HelloWorld Process
Date Tue, 19 May 2009 18:38:34 GMT
Hi Naoki,

as far as I can tell, your Eclipse should work in the configuration you
have. However, the error log of ODE seems to be a bit strange. I haven't
seen any java.io.WinNTFileSystem.createFileExclusively yet.  Perhaps
some ODEer can comment on this? Perhaps some permission issues?
If you like, you can email me your process (including wsdls and
deploy.xml) and I can have a look.

Daniel


Naoki Okitsu schrieb:
> Hello Daniel
>
> Thank you for replying my question.
> I downloaded these zip files and unzip them.
> emf-runtime-2.4.2.zip
> GEF-SDK-3.4.2.zip
> VE-runtime-1.2.3_jem.zip
> wtp-R-3.0.4-20090213193639.zip
>
> I copied all files and all directories from below.
> wtp-R-3.0.4-20090213193639\eclipse\plugins\*
> VE-runtime-1.2.3_jem\eclipse\plugins\*
> GEF-SDK-3.4.2\eclipse\plugins\*
> emf-runtime-2.4.2\eclipse\plugins\*
>
> And I pasted them to below directory.
> C:\eclipse\plugins
> This is my eclipse home.
>
> Thanks to your advice,I could see "Web Services>Test with Web Services
> Explore" menu.
> But I got "HelloWorldReponse result(string)null".
> I can't get correct response.
>                                      
> I use below environment.
> jdk1.6.0_13
> Eclipse SDK Version: 3.4.2
> Apache Tomcat Version 6.0.18
> Apache ODE 1.3.2
>
> To solve this problem,I am going to remove eclipse folder and install again.
> If you knew correct plugins to run Hello World Process,please tell me.
> Shoud I use another plugins?
>
> I get many errors message from console like this.
> ERROR - GeronimoLog.error(108) | Could not save bad job; it will be lost:
> hqejbhcnphr4acsr0gj8ox 
>  [3]: {final=true, mexid=hqejbhcnphr4acsr0gj8j9,
> pid={http://helloWorld}HelloWorld-7, type=INVOKE_INTERNAL, retry=3}
> java.io.IOException: 
> 	at java.io.WinNTFileSystem.createFileExclusively(Native Method)
> 	at java.io.File.checkAndCreate(Unknown Source)
> 	at java.io.File.createTempFile(Unknown Source)
> 	at
> org.apache.ode.bpel.engine.BpelEngineImpl.checkRetry(BpelEngineImpl.java:377
> )
> 	at
> org.apache.ode.bpel.engine.BpelEngineImpl.onScheduledJob(BpelEngineImpl.java
> :336)
> 	at
> org.apache.ode.bpel.engine.BpelServerImpl.onScheduledJob(BpelServerImpl.java
> :373)
> 	at
> org.apache.ode.scheduler.simple.SimpleScheduler$4$1.call(SimpleScheduler.jav
> a:337)
> 	at
> org.apache.ode.scheduler.simple.SimpleScheduler$4$1.call(SimpleScheduler.jav
> a:336)
> 	at
> org.apache.ode.scheduler.simple.SimpleScheduler.execTransaction(SimpleSchedu
> ler.java:174)
> 	at
> org.apache.ode.scheduler.simple.SimpleScheduler$4.call(SimpleScheduler.java:
> 335)
> 	at
> org.apache.ode.scheduler.simple.SimpleScheduler$4.call(SimpleScheduler.java:
> 332)
> 	at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
> 	at java.util.concurrent.FutureTask.run(Unknown Source)
> 	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown
> Source)
> 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown
> Source)
> 	at java.lang.Thread.run(Unknown Source)
> DEBUG - GeronimoLog.debug(66) | GET MEX property
> org.apache.ode.bpel.myRoleSessionId = null
> DEBUG - GeronimoLog.debug(66) | GET MEX property
> org.apache.ode.bpel.myRoleSessionId = null
> ....
>
>  
>   
>> Hello Naoki,
>>
>> this means that the corresponding Eclipse plug-in is missing. You should
>> have installed the Web Tools Project (or alternative install the JEE
>> Eclipse edition available from eclipse.org and install the BPELEditor
>> and stuff in there).
>>
>> Daniel
>>
>> Naoki Okitsu schrieb:
>>     
>>> Hello
>>>
>>> My name is naoki okitsu.
>>> I tried Hello World Process with referring Tutorials.
>>> But I encountered problem .
>>> There is no "Web Service"/Test with Web Services Explorer"menu.
>>>
>>> Can I ask this problem?
>>>
>>> Thanks in advance.
>>>
>>>       
>
>
>   


Mime
View raw message