ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Victor Chirita <victor.chir...@gmail.com>
Subject ApacheODE 1.2 + Hibernate + Tomcat 6.0.18 on Oracle 9 configuration Problems
Date Fri, 08 May 2009 09:13:24 GMT

 Hello to everybody,

This is my first post here and I'm asking for your help with the matter in
the title.

I've been trying to configure Ode to use Hibernate as persistency layer in
Tomcat 6.0.18 with Oracle 9 as database for a few days now and no luck. I'll
be very grateful if someone can point me in the right direction with this
since I've not been able to find information on how to configure it. I've
read the messages on http://www.nabble.com/Apache-Ode-User-f16255.html but
with no luck finding what I need. I want to know the necessary steps to make
the configuration run.


What I did:
deployed in Tomcat apache-ode-war-1.2 - OK (with derby database)
after test with derby which is ok, I tried to switch to Oracle (the database
that we currently use)
changed ode\WEB-INF\conf\ode-axis2.properties with the following entries:

# ODE Configuration
# Database mode property specify whether to use embedded db or external.
ode-axis2.db.mode=EXTERNAL
# Previously created data source name.
ode-axis2.db.ext.dataSource=java:comp/env/jdbc/OdeDb

ode-axis2.dao.factory=org.apache.ode.daohib.bpel.BpelDAOConnectionFactoryImpl
org.hibernate.dialect.Dialect=org.hibernate.dialect.Oracle9Dialect

## Process dehydration
## wait for 5 minutes instead of 20 minutes
ode-axis2.process.dehydration.maximum.age=300000 

# allow not more than 500 processes to be in memory at once
ode-axis2.process.dehydration.maximum.count=500

is it ok to add to the same file the following:
# Hibernate Configuration
hibernate.hbm2ddl.auto=update
for hibernate?

added the file context.xml in ode\META-INF\context.xml with the following
contents:
<Context path="/ode" docBase="ode" debug="5" reloadable="true"
crossContext="true">
	<Resource name="jdbc/OdeDb" auth="Container" 
	       type="javax.sql.DataSource" maxActive="100" maxIdle="30"
maxWait="10000"
	       username="ode"  password="bapro77"
               driverClassName="oracle.jdbc.OracleDriver"
               url="jdbc:oracle:thin:@192.168.0.5:1521:BAPRO"/>
</Context>

added the folowing jars to tomcat\lib (as specified in the tomcat6
configuration)
antlr-2.7.6.jar
asm-1.5.3.jar
cglib-2.1_3.jar
ehcache-1.2.3.jar
hibernate-3.2.5.ga-bundle.jar
ojdbc14.jar

no jars added to web-inf/lib of deployed war file.

The output of the console is:
... ... ...
DEBUG - GeronimoLog.debug(66) | Loading properties
DEBUG - GeronimoLog.debug(66) | Initializing transaction manager
DEBUG - GeronimoLog.debug(66) | Initializing transaction manager using
org.apache.ode.il.EmbeddedGeronimoFactory
DEBUG - GeronimoLog.debug(66) | Creating data source.
DEBUG - GeronimoLog.debug(66) | Starting DAO.
INFO - GeronimoLog.info(79) | Using DAO Connection Factory class
org.apache.ode.daohib.bpel.BpelDAOConnectionFactoryImpl.
May 8, 2009 4:33:03 AM org.apache.coyote.http11.Http11AprProtocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
May 8, 2009 4:33:03 AM org.apache.coyote.ajp.AjpAprProtocol start
INFO: Starting Coyote AJP/1.3 on ajp-8009
May 8, 2009 4:33:03 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 31540 ms

NO ERRORS but the init of the BPEL Server does not occur.

Please help me to resolve this problem since after 3 days it starts to drive
me crazy and i'm feeling i'm loosing my sense. Please advise if it is easier
to switch to OpenJPA and how to do that.
-- 
View this message in context: http://www.nabble.com/ApacheODE-1.2-%2B-Hibernate-%2B-Tomcat-6.0.18-on-Oracle-9-configuration-Problems-tp23442676p23442676.html
Sent from the Apache Ode User mailing list archive at Nabble.com.


Mime
View raw message