ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hans-Peter Schmidt" <chojinz...@mail.com>
Subject ws-adddressing.headers
Date Tue, 19 May 2009 07:34:13 GMT
 Well ok, but the typo aside.
How do i get rid of the ws-addressing headers then?
The endpoint file i created doesn't seem to affect it at all.
I tried 2 and 3 d's
Here is my endpoint file.


Hi Hans-Peter,

obviously you're right. There's a typo in the property name [1]. Someone
drank to much caffeine that day...
consequently, you do need to type 3 'd's in your property files.
I filled an issue: ODE-607.

Sorry about that.

Alexis

[1]
http://svn.apache.org/viewvc/ode/branches/APACHE_ODE_1.X/utils/src/main/java/org/apache/ode/utils/Properties.java?revision=765012&pathrev=765012


2009/5/18 Hans-Peter Schmidt <chojinzero@mail.com>

> Hello,
> i want to disable ws-addressing in the soap messages generated by ode.
> I read that you have to create an *.endpoint file in your process
> directory and add the following line to disable ws-addressing:
> ws-adddressing.heade

rs=false
> (only line in the file)
>
> Are the 3 'd' in adddressing correct? doesn't work with 2 'd' too.
> Filename is process.endpoint
> Location is \ode\WEB-INF\processes\myprocess
>
> So i did. Now even after restarting ode or waiting for over 30 seconds,
> the addressing content is still in the soap header.
>
> <soapenv:Header>
> <addr:To
> xmlns:addr="http://www.w3.org/2005/08/addressing">http://localhost:
> ...
>
> what do i do wrong?
>
> ODE Version = 1.3.2
> Tomcat Version = 6.0.18
>
> Thanks in advance.
>
> --
> Be Yourself @ mail.com!
> Choose From 200+ Email Addresses
> Get a Free Account at www.mail.com
>
>

-- 
Be Yourself @ mail.com!
Choose From 200+ Email Addresses
Get a Free Account at www.mail.com


Mime
  • Unnamed multipart/mixed (inline, 7-Bit, 0 bytes)
View raw message