ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Boisvert <boisv...@intalio.com>
Subject Re: Different responses from same BPEL process in Tomcat and ServiceMix
Date Thu, 19 Feb 2009 22:39:53 GMT
It does look like a bug... please file an issue @ issues.apache.org.   I
don't think anyone is actively working on the JBI integration so if you do
have a few cycles to debug it, that might be your best bet.

alex


On Thu, Feb 19, 2009 at 9:01 AM, Harshit Kapoor <hkapoor@ciber.com> wrote:

> Hi.
>
>
>
> I am get different response (for same request message) from same BPEL
> process deployed in Tomcat and ServiceMix.
>
> Here are the details.
>
>
>
> ODE_VERSION = apache-ode-war-1.2.zip
>
> DEPLOYED_IN = apache-tomcat-5.5.26
>
> BPEL = Created with Eclipse BPELDesigner, used SOAP Doc/Lit Binding for
> serving requests.
>
>
>
> Following response is received in Eclipse Webservice Tester
>
>
>
> <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/
> ">
>
> <soapenv:Body>
>
> <ENVELOPE xmlns="http://www.ciber.com/GEIP/SOAPOC/CanonicalContent.xsd">
> <CMH xmlns:SOAP-ENV="http://www.w3.org/2003/05/soap-envelope"
> xmlns:ns0="http://www.ciber.com/GEIP/SOAPOC/CanonicalContent.xsd"> ...
> </CMH> <RESULT_STACK> ... </RESULT_STACK> </ENVELOPE>
>
> </soapenv:Body>
>
> </soapenv:Envelope>
>
>
>
> ///////////////////////////////
>
>
>
> ODE_VERSION = ode-jbi-1.2.zip
>
> DEPLOYED_IN = apache-servicemix-3.2.2
>
> BPEL = Same BPEL Process used as above
>
> MESSAGE_MAPPER =
> ode-jbi.messageMapper=org.apache.ode.jbi.msgmap.JbiWsdl11WrapperMapper
> (does
> not work with other 2 mappers)
>
>
>
> Following response is received in Eclipse Webservice Tester
>
>
>
> <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
>
> <soap:Body>
>
> <ENVELOPE> <ns0:CMH xmlns:SOAP-ENV="
> http://www.w3.org/2003/05/soap-envelope"
> xmlns:ns0="http://www.ciber.com/GEIP/SOAPOC/CanonicalContent.xsd">  ...
> </ns0:CMH> <ns0:RESULT_STACK
> xmlns:ns0="http://www.ciber.com/GEIP/SOAPOC/CanonicalContent.xsd"> ...
> </ns0:RESULT_STACK> </ENVELOPE>
>
> </soap:Body>
>
> </soap:Envelope>
>
>
>
> Note that ENVELOPE element in first case belongs to
> http://www.ciber.com/GEIP/SOAPOC/CanonicalContent.xsd (correct response)
>
> however in second case it belongs to
> http://schemas.xmlsoap.org/soap/envelope/ (incorrect response)
>
>
>
> I do not know the problem, probably it is related to message translation
> from ODE to NMR or from NMR to BC.
>
>
>
> Please Help!
>
>
>
> -Harshit
>
>
>
>
>
>
>
>
>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message