ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sandrine Beauche <sandrine.beau...@club-internet.fr>
Subject Re: assign with complex types
Date Wed, 10 Dec 2008 14:05:01 GMT

please! could you help me???

Sandrine.


Sandrine Beauche wrote:
> 
> Hi Alex,
> 
> ok, I've resent the exemple with a zip  archive
> 
> Sandrine.
> 
> 
http://www.nabble.com/file/p20919709/HelloWorld2.zip HelloWorld2.zip 


Alex Boisvert-3 wrote:
> 
> Hi Sandrine,
> 
> I don't see a problem with your assignments.
> 
> Your attachments were truncated.  Could you zip them and resend?
> 
> alex
> 
> 
> On Tue, Dec 9, 2008 at 8:22 AM, Sandrine Beauche <
> sandrine.beauche@club-internet.fr> wrote:
> 
>>
>> I've tried to do an assign from a complex type to another variable, and
>> this
>>  works when the complex type has one subtype.
>>
>> But my problem is to do this with a complex type that have several
>> subtype.
>> I
>>  have in my wsdl this complex type:
>>
>> <xsd:complexType name="helloType">
>>    <xsd:sequence>
>>        <xsd:element name="hello1" type="xsd:string"/>
>>        <xsd:element name="hello2" type="xsd:string"/>
>>    </xsd:sequence>
>> </xsd:complexType>
>>
>> and the message:
>>
>> <wsdl:message name="HelloMessage">
>>    <wsdl:part name="TestPart" type="nsxsd:helloType"/>
>> </wsdl:message>
>>
>> In my BPEL, I have these variable
>>
>> <variable name="myVar" messageType="test:HelloMessage"/>
>> <variable name="tmpVar1" type="xsd:string"/>
>> <variable name="tmpVar2" type="xsd:string"/>
>>
>> and I want to do these assign:
>>
>> <copy>
>>    <from>$myVar.TestPart/nsxsd:hello1</from>
>>    <to variable="tmpVar1"/>
>> </copy>
>> <copy>
>>    <from>$myVar.TestPart/nsxsd:hello2</from>
>>    <to variable="tmpVar2"/>
>> </copy>
>>
>> But this does'nt work. I obtain a message fault:
>>
>> <soapenv:Body>
>>    <soapenv:Fault>
>>        <faultcode>soapenv:Server</faultcode>
>>        <faultstring xmlns:axis2ns1="http://docs.oasis
>>  open.org/wsbpel/2.0/proces /executable"> axis2ns1:selectionFailure
>>        </faultstring>
>>        <detail />
>>    </soapenv:Fault>
>> </soapenv:Body>
>>
>> What's wrong in my bpel or wsdl? The complete bpel and wsdl are attached.
>> I
>>  have also attached a soap message that i send to the process to test it.
>>
>> --
>> Thanks.
>>
>>
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/assign-with-complex-types-tp20919141p20935995.html
Sent from the Apache Ode User mailing list archive at Nabble.com.


Mime
View raw message