ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rat...@wso2.com
Subject Re: Responses are undefined when try to communicate with InstantManagementAPI
Date Tue, 25 Nov 2008 15:27:11 GMT
Hi Alex,

I tried in both IE7 and Firefox 3.0 and got same issue. Please can you say
me how you checked it? i checked using java script and html file.

Thanks.
ratha.

> This URL works fine for me, did you try it in a browser?
>
> alex
>
>
> On Tue, Nov 25, 2008 at 2:17 AM, ratha <rathav@wso2.com> wrote:
>
>> Hi all,
>>
>> When  I send XMLHttpRequest() to the following URL "
>> http://localhost:8080/ode/processes/InstanceManagement/listAllInstances"
>> server states as follows,
>>
>> *DEBUG - GeronimoLog.debug(66) | Found a header in incoming message,
>> checking if
>> there are endpoints there.
>> DEBUG - GeronimoLog.debug(66) | Found a header in incoming message,
>> checking if
>> there are endpoints there*
>>
>> No output from the XMLHttp request. When I print the response of a
>> single
>> element(from the XMLHttp request) it states *'undefined'*.
>> So, I tried to create an object for InstantManagementAPI like,
>> *instances_available  = InstanceManagementService.listAllInstances();  *
>>
>> but it throws an exception like "*No response undefined*".
>>
>> It seems some error in my back end server. Do I need to do any
>> modifications at the configuration of ODE  in order to make above
>> communications? or some other errors in my back end service?
>>
>> Any assistance will be really helpful to me.
>> .
>> Thanks.
>> -Ratha.
>>
>


Mime
View raw message