ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "binh nguyen" <linhtinh0...@gmail.com>
Subject Re: An error when run BPEL
Date Wed, 12 Nov 2008 05:34:20 GMT
Hi Rathar and Alex,
Thank you for your response, but I still do not know more concretely
 how to correct the initialization of the variables. Here I show my Bpel
and related WSDL and Schema files. Please take a look and show
me what I need to do to correct the error.

BPEL file: testBP.bpel

<?xml version="1.0" encoding="UTF-8"?>
<process
    name="testBP"
    targetNamespace="http://enterprise.netbeans.org/bpel/StringBP/testBP"
    xmlns="http://docs.oasis-open.org/wsbpel/2.0/process/executable"
    xmlns:xsd="http://www.w3.org/2001/XMLSchema"
    xmlns:sxt="
http://www.sun.com/wsbpel/2.0/process/executable/SUNExtension/Trace"
    xmlns:sxed="
http://www.sun.com/wsbpel/2.0/process/executable/SUNExtension/Editor"
    xmlns:tns="http://enterprise.netbeans.org/bpel/StringBP/testBP">

    <import namespace="http://j2ee.netbeans.org/wsdl/testBP"
        location="testBP.wsdl"
        importType="http://schemas.xmlsoap.org/wsdl/"/>
    <import namespace="
http://enterprise.netbeans.org/bpel/StringWSServiceWrapper"
        location="StringWSServiceWrapper.wsdl"
        importType="http://schemas.xmlsoap.org/wsdl/"/>
    <import namespace="http://MyWebServices/"
        location="StringWSService.wsdl"
        importType="http://schemas.xmlsoap.org/wsdl/"/>

    <partnerLinks>
        <partnerLink name="StringPL"
            xmlns:tns="
http://enterprise.netbeans.org/bpel/StringWSServiceWrapper"
            partnerLinkType="tns:StringWSLinkType"
partnerRole="StringWSRole"
            initializePartnerRole="yes"/>
        <partnerLink name="TestPartnerLink"
            xmlns:tns="http://j2ee.netbeans.org/wsdl/testBP"
            partnerLinkType="tns:testBPLT" myRole="testBPPortTypeRole"/>
    </partnerLinks>
    <variables>
        <variable name="ReverseOut" xmlns:tns="http://MyWebServices/"
            messageType="tns:reverseResponse"/>
        <variable name="ReverseIn" xmlns:tns="http://MyWebServices/"
            messageType="tns:reverse"/>
        <variable name="TestBPOperationOut" xmlns:tns="
http://j2ee.netbeans.org/wsdl/testBP"
            messageType="tns:testBPOperationResponse"/>
        <variable name="TestBPOperationIn" xmlns:tns="
http://j2ee.netbeans.org/wsdl/testBP"
            messageType="tns:testBPOperationRequest"/>
    </variables>
    <sequence>
        <receive name="Receive1" createInstance="yes"
            partnerLink="TestPartnerLink"
            operation="testBPOperation"
            xmlns:tns="http://j2ee.netbeans.org/wsdl/testBP"
            portType="tns:testBPPortType"
            variable="TestBPOperationIn"/>
        <assign name="Assign1">
            <copy>
                <from variable="TestBPOperationIn" part="partIn"/>
                <to>$ReverseIn.parameters/inputString</to>
            </copy>
        </assign>
        <invoke name="Invoke1" partnerLink="StringPL"
            operation="reverse" xmlns:tns="http://MyWebServices/"
            portType="tns:StringWS"
            inputVariable="ReverseIn" outputVariable="ReverseOut"/>
        <assign name="Assign2">
            <copy>
                <from>$ReverseOut.parameters/return</from>
                <to variable="TestBPOperationOut" part="partOut"/>
            </copy>
        </assign>
        <reply name="Reply1" partnerLink="TestPartnerLink"
            operation="testBPOperation"
            xmlns:tns="http://j2ee.netbeans.org/wsdl/testBP"
            portType="tns:testBPPortType"
            variable="TestBPOperationOut"/>
    </sequence>
</process>

------------------------------
WSDL File: testBP.wsdl

<?xml version="1.0" encoding="UTF-8"?>
<definitions name="testBP" targetNamespace="
http://j2ee.netbeans.org/wsdl/testBP"
    xmlns="http://schemas.xmlsoap.org/wsdl/"
    xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
    xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:tns="
http://j2ee.netbeans.org/wsdl/testBP" xmlns:plnk="
http://docs.oasis-open.org/wsbpel/2.0/plnktype" xmlns:soap="
http://schemas.xmlsoap.org/wsdl/soap/">
    <types/>
    <message name="testBPOperationRequest">
        <part name="partIn" type="xsd:string"/>
    </message>
    <message name="testBPOperationResponse">
        <part name="partOut" type="xsd:string"/>
    </message>
    <portType name="testBPPortType">
        <operation name="testBPOperation">
            <input name="input1" message="tns:testBPOperationRequest"/>
            <output name="output1" message="tns:testBPOperationResponse"/>
        </operation>
    </portType>
    <binding name="testBPBinding" type="tns:testBPPortType">
        <soap:binding style="rpc" transport="
http://schemas.xmlsoap.org/soap/http"/>
        <operation name="testBPOperation">
            <soap:operation/>
            <input name="input1">
                <soap:body use="literal" namespace="
http://j2ee.netbeans.org/wsdl/testBP"/>
            </input>
            <output name="output1">
                <soap:body use="literal" namespace="
http://j2ee.netbeans.org/wsdl/testBP"/>
            </output>
        </operation>
    </binding>
    <service name="testBPService">
        <port name="testBPPort" binding="tns:testBPBinding">
            <soap:address location="
http://localhost:8084/ode/processes/testBP"/>
        </port>
    </service>
    <plnk:partnerLinkType name="testBPLT">

        <plnk:role name="testBPPortTypeRole" portType="tns:testBPPortType"/>
    </plnk:partnerLinkType>
</definitions>

------------------------------
WSDL file: StringWSService.wsdl

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<!-- Generated by JAX-WS RI at http://jax-ws.dev.java.net. RI's version is
JAX-WS RI 2.1.4-b01-. -->
<definitions targetNamespace="http://MyWebServices/" name="StringWSService"
xmlns="http://schemas.xmlsoap.org/wsdl/" xmlns:tns="http://MyWebServices/"
xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:soap="
http://schemas.xmlsoap.org/wsdl/soap/">
  <types>
    <xsd:schema>
      <xsd:import namespace="http://MyWebServices/"
schemaLocation="StringWSService_schema1.xsd"/>
    </xsd:schema>
  </types>
  <message name="testString">
    <part name="parameters" element="tns:testString"/>
  </message>
  <message name="testStringResponse">
    <part name="parameters" element="tns:testStringResponse"/>
  </message>
  <message name="reverse">
    <part name="parameters" element="tns:reverse"/>
  </message>
  <message name="reverseResponse">
    <part name="parameters" element="tns:reverseResponse"/>
  </message>
  <portType name="StringWS">
    <operation name="testString">
      <input message="tns:testString"/>
      <output message="tns:testStringResponse"/>
    </operation>
    <operation name="reverse">
      <input message="tns:reverse"/>
      <output message="tns:reverseResponse"/>
    </operation>
  </portType>
  <binding name="StringWSPortBinding" type="tns:StringWS">
    <soap:binding transport="http://schemas.xmlsoap.org/soap/http"
style="document"/>
    <operation name="testString">
      <soap:operation soapAction=""/>
      <input>
        <soap:body use="literal"/>
      </input>
      <output>
        <soap:body use="literal"/>
      </output>
    </operation>
    <operation name="reverse">
      <soap:operation soapAction=""/>
      <input>
        <soap:body use="literal"/>
      </input>
      <output>
        <soap:body use="literal"/>
      </output>
    </operation>
  </binding>
  <service name="StringWSService">
    <port name="StringWSPort" binding="tns:StringWSPortBinding">
      <soap:address location="http://localhost:8084/MyWS/StringWS"/>
    </port>
  </service>
</definitions>

------------------------------
WSDL file: StringWSServiceWrapper.wsdl

<?xml version="1.0" encoding="UTF-8"?>

<definitions
    xmlns="http://schemas.xmlsoap.org/wsdl/"
    xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
    xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
    xmlns:xsd="http://www.w3.org/2001/XMLSchema"
name="StringWSServiceWrapper" targetNamespace="
http://enterprise.netbeans.org/bpel/StringWSServiceWrapper" xmlns:tns="
http://enterprise.netbeans.org/bpel/StringWSServiceWrapper" xmlns:plnk="
http://docs.oasis-open.org/wsbpel/2.0/plnktype" xmlns:ns="
http://MyWebServices/">
    <import location="StringWSService.wsdl" namespace="http://MyWebServices/
"/>
    <plnk:partnerLinkType name="StringWSLinkType">
        <plnk:role name="StringWSRole" portType="ns:StringWS"/>
    </plnk:partnerLinkType>
</definitions>

------------------------------
Schema WSDL file:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<xs:schema version="1.0" targetNamespace="http://MyWebServices/" xmlns:tns="
http://MyWebServices/" xmlns:xs="http://www.w3.org/2001/XMLSchema">

  <xs:element name="reverse" nillable="true" type="tns:reverse"/>

  <xs:element name="reverseResponse" nillable="true"
type="tns:reverseResponse"/>

  <xs:element name="testString" nillable="true" type="tns:testString"/>

  <xs:element name="testStringResponse" nillable="true"
type="tns:testStringResponse"/>

  <xs:complexType name="testString">
    <xs:sequence/>
  </xs:complexType>

  <xs:complexType name="testStringResponse">
    <xs:sequence>
      <xs:element name="return" type="xs:string" minOccurs="0"/>
    </xs:sequence>
  </xs:complexType>

  <xs:complexType name="reverse">
    <xs:sequence>
      <xs:element name="inputString" type="xs:string" minOccurs="0"/>
    </xs:sequence>
  </xs:complexType>

  <xs:complexType name="reverseResponse">
    <xs:sequence>
      <xs:element name="return" type="xs:string" minOccurs="0"/>
    </xs:sequence>
  </xs:complexType>
</xs:schema>

------------------------------

Thank you very much!
Binh.



2008/11/11 ratha <rathav@wso2.com>

> Hi Binh,
>
> I also faced such issue with SOAPUI. Check your assign activity whether you
> assigned values correctly for the 'from' and 'to' parts.
>
> Regards
> -ratha.
>
> binh nguyen wrote:
>
>> Hi all,
>> I encounter the same error when run some BPEL processes.
>> I am using Tomcat 6.0.16, ODE 1.2, Java JDK 1.5, and also using
>> SOAPUI to test the result of BPEL after having deployed. The deployment
>> of the processes is OK, but when tested with soapUI, there is following
>> error:
>>
>> <soapenv:Envelope xmlns:soapenv="
>> http://schemas.xmlsoap.org/soap/envelope/">
>>   <soapenv:Body>
>>      <soapenv:Fault>
>>         <faultcode>soapenv:Server</faultcode>
>>         <faultstring xmlns:axis2ns11="
>> http://docs.oasis-open.org/wsbpel/2.0/process/executable
>> ">axis2ns11:selectionFailure</faultstring>
>>         <detail/>
>>      </soapenv:Fault>
>>   </soapenv:Body>
>> </soapenv:Envelope>
>>
>> Any one has any idea about this kind of error?
>> Thank you!
>> Binh.
>>
>>  ------------------------------------------------------------------------
>>
>>
>> No virus found in this incoming message.
>> Checked by AVG - http://www.avg.com Version: 8.0.175 / Virus Database:
>> 270.9.0/1779 - Release Date: 11/10/2008 7:53 AM
>>
>>
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message