ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthieu Riou" <matth...@offthelip.org>
Subject Re: Trunk build problems
Date Wed, 22 Oct 2008 15:42:02 GMT
On Wed, Oct 22, 2008 at 8:35 AM, Alexander Bruckner <
alexander_bruckner@gmx.at> wrote:

> Matthieu Riou schrieb:
>
>  On Tue, Oct 21, 2008 at 1:43 PM, Alexander Bruckner <
>> alexander_bruckner@gmx.at> wrote:
>>
>>  Hi,
>>>
>>> i'm struggling with the trunk build
>>>
>>> This command:
>>> /var/lib/gems/1.8/bin/rake --trace _0.8.3_ package
>>>
>>> gives me this output:
>>> rake aborted!
>>> RubyGem version error: rake(0.8.3 not = 0.8.1)
>>> ...
>>>
>>> If I try rake 0.8.1:
>>> /var/lib/gems/1.8/bin/rake --trace _0.8.1_ package
>>>
>>> i get:
>>> rake aborted!
>>> RubyGem version error: rake(0.8.1 not >= 0.8.3)
>>>
>>> I've followed the build guide (http://ode.apache.org/building-ode.html)
>>> so
>>> far and also tried the standard commands from the guide without success.
>>>
>>> Can someone help me out here ? Are there maybe alternative ways of
>>> building
>>> the trunk ?
>>>
>>>
>> You should first try to update RubyGems:
>>
>>  gem update --system
>>
>> Then to build just do:
>>
>>  buildr clean ode:package
>>
>> If you get that version problem with rake again, try to install Rake
>> 0.8.1:
>>
>>  gem install rake -v 0.8.1
>>
>> Hopefully that should get you through.
>>
>>
> Thanks for your help.
>
> Finally I've managed a successful build. I'm not 100 percent sure, what the
> really necessary steps were after many attempts, but among the last were:
>
> -update RubyGems:
> gem update --system
>
> -install the newest buildr:
> gem install buildr (newest version was 1.3.3, only rake version currently
> installed is 0.8.1)
>
> -correct "errors" (maybe specific to my system ?) in the Rakefile:
> --around line 179, error ~ undefined alias -> exchange the two lines "alias
> :tag :tag_with_apache_ode" & "alias :tag_without_apache_ode :tag"
> --around line 555:, error ~ undefined constant "Java::JUnit::" -> I've just
> deleted this bit
>

Were you trying to build the 1.X branch? 1.X is a stable branch so it still
relies on Buildr 1.2.10. The trunk uses the latest. So your tweaks is
essentially what we had to do to upgrade from 1.2.10 to 1.3.3 :)

Anyway if that works for you, it's all good.

Matthieu


>
> Best,
> Alex
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message