ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthieu Riou" <matth...@offthelip.org>
Subject Re: Trunk build problems
Date Wed, 22 Oct 2008 00:13:16 GMT
On Tue, Oct 21, 2008 at 1:43 PM, Alexander Bruckner <
alexander_bruckner@gmx.at> wrote:

> Hi,
>
> i'm struggling with the trunk build
>
> This command:
> /var/lib/gems/1.8/bin/rake --trace _0.8.3_ package
>
> gives me this output:
> rake aborted!
> RubyGem version error: rake(0.8.3 not = 0.8.1)
> ...
>
> If I try rake 0.8.1:
> /var/lib/gems/1.8/bin/rake --trace _0.8.1_ package
>
> i get:
> rake aborted!
> RubyGem version error: rake(0.8.1 not >= 0.8.3)
>
> I've followed the build guide (http://ode.apache.org/building-ode.html) so
> far and also tried the standard commands from the guide without success.
>
> Can someone help me out here ? Are there maybe alternative ways of building
> the trunk ?
>

You should first try to update RubyGems:

  gem update --system

Then to build just do:

  buildr clean ode:package

If you get that version problem with rake again, try to install Rake 0.8.1:

  gem install rake -v 0.8.1

Hopefully that should get you through.

Matthieu


>
> best,
> Alex
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message