ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Boisvert" <boisv...@intalio.com>
Subject Re: REST Post issue
Date Fri, 31 Oct 2008 19:27:31 GMT
It might be worth a shot to post on the axis2 mailing list.   I'm also
suspecting this behavior might be specific to the servlet engine since
that's where most of the HTTP protocol processing happens.

alex


On Fri, Oct 31, 2008 at 11:18 AM, Chris Taylor <saursoor@yahoo.com> wrote:

> A service we are invoking from a bpel implements a REST Post operation.
>
> This is failing for us with a 400 response error.  After some digging into
> the problem, it seems that our request header is a) not sending the Host
> header and/or b) not setting the Post URI correctly.
>
> the request/response headers:
>
> POST
> http://ccswsappsrv-v3-test.uhc.com/CCReview/CoderLookupService.svc/GetCodesAndDesc/
> Request Headers:
> Accept: text/xml
> Request Entity:
> Content-Type:text/xml; charset=ISO-8859-1
> Content-Length:459
> Content-Charset:ISO-8859-1
> Request Entity:
> <?xml version="1.0" encoding="UTF-8"?>
> <DiagnosisLookup xmlns="http://tempuri.org/">
> <MaxNumberOfCodes xmlns="">5</MaxNumberOfCodes>
> <SearchText xmlns="">100.8</SearchText>
> <SearchType xmlns="">Full</SearchType>
> <CoderType xmlns="">Codes/ICD9 Diagnosis</CoderType>
> </DiagnosisLookup>
>
> POST
> http://ccswsappsrv-v3-test.uhc.com/CCReview/CoderLookupService.svc/GetCodesAndDesc/
> Status-Line<http://ccswsappsrv-v3-test.uhc.com/CCReview/CoderLookupService.svc/GetCodesAndDesc/Status-Line>:
> HTTP/1.1 400 Bad Request
> Response Headers:
> Date: Fri, 31 Oct 2008 18:09:50 GMT
> Server: Microsoft-IIS/6.0
> X-Powered-By: ASP.NET
> X-AspNet-Version: 2.0.50727
> Cache-Control: private
> Content-Length: 0
>
> when i send the same request, via soapui but modify the request header to
> say:
>
> POST /CCReview/CoderLookupService.svc/GetCodesAndDesc/
> Host: ccswsappsrv-v3-test.uhc.com
>
> I get the desired REST http 200 response.  are these request header
> settings configurable in the Axis2 layer?  What settings would they be?
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message