ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthias Richter <matthi...@gmail.com>
Subject Re: Service not found at EPR
Date Mon, 15 Sep 2008 15:02:15 GMT
I'm sorry Matthieu, I don't know what you mean with clean Axis  
instance? I have deployed a axis instance in Tomcat besides ode  
though, running some web services there.

By the way: it is just happening when running ode built out of trunk,  
the 1.2 doesn't show this behavior...


-- Matthias


Am 15.09.2008 um 16:46 schrieb Matthieu Riou:

> On Mon, Sep 15, 2008 at 5:49 AM, Matthias Richter  
> <matthiasr@gmail.com>wrote:
>
>> Hi,
>>
>> I'm using a simple SOAP Client to test my process deployed in ODE  
>> locally.
>> The WSDL ist located at
>> http://localhost:8080/ode/services/SynchronousSample?wsdl and a  
>> client can
>> be generated (the SOAP adress is correct, too).
>>
>> When invoking the process, I get an exception in Tomcat though:
>>
>> [ERROR] The service cannot be found for the endpoint reference (EPR)
>> http://localhost/ode/processes/SynchronousSample
>> org.apache.axis2.AxisFault: The service cannot be found for the  
>> endpoint
>> reference (EPR) http://localhost/ode/processes/SynchronousSample
>>       at
>> org 
>> .apache 
>> .axis2.engine.DispatchPhase.checkPostConditions(DispatchPhase.java: 
>> 65)
>>       at org.apache.axis2.engine.Phase.invoke(Phase.java:333)
>>       at org.apache.axis2.engine.AxisEngine.invoke(AxisEngine.java: 
>> 264)
>>       at org.apache.axis2.engine.AxisEngine.receive(AxisEngine.java: 
>> 163)
>>       at
>> org 
>> .apache 
>> .axis2 
>> .transport 
>> .http 
>> .HTTPTransportUtils.processHTTPPostRequest(HTTPTransportUtils.java: 
>> 275)
>>       at
>> org.apache.axis2.transport.http.AxisServlet.doPost(AxisServlet.java: 
>> 133)
>>       at javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
>>       at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
>>       at
>> org 
>> .apache 
>> .catalina 
>> .core 
>> .ApplicationFilterChain 
>> .internalDoFilter(ApplicationFilterChain.java:290)
>>       at
>> org 
>> .apache 
>> .catalina 
>> .core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java: 
>> 206)
>>       at
>> org 
>> .apache 
>> .catalina 
>> .core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
>>       at
>> org 
>> .apache 
>> .catalina 
>> .core.StandardContextValve.invoke(StandardContextValve.java:191)
>>       at
>> org 
>> .apache 
>> .catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
>>       at
>> org 
>> .apache 
>> .catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
>>       at
>> org 
>> .apache 
>> .catalina.core.StandardEngineValve.invoke(StandardEngineValve.java: 
>> 109)
>>       at
>> org 
>> .apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java: 
>> 286)
>>       at
>> org 
>> .apache.coyote.http11.Http11Processor.process(Http11Processor.java: 
>> 845)
>>       at
>> org.apache.coyote.http11.Http11Protocol 
>> $Http11ConnectionHandler.process(Http11Protocol.java:583)
>>       at
>> org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java: 
>> 447)
>>       at java.lang.Thread.run(Thread.java:613)
>>
>>
>> Please notice that in the exception stack trace the local port  
>> (8080) is
>> missing. Is that a configuration problem? Problem is showing up  
>> with the ODE
>> examples as well.
>>
>
> Have you tired using a clean Axis2 instance instead of reusing the  
> ODE one?
> The problem is probably that we have to customize the Axis2  
> configuration
> quite a bit for ODE (i.e. /processes/ instead of /services/) and that
> usually doesn't play nice with other, more neutral services.
>
> Matthieu
>
>
>>
>> Thanks for your help
>>
>> --Matthias
>>
>>


Mime
View raw message