ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthieu Riou" <matth...@offthelip.org>
Subject Re: Using element type variable in receive/reply
Date Thu, 24 Jul 2008 15:17:58 GMT
On Thu, Jul 24, 2008 at 12:53 AM, Raphael Parree <rparree@gmail.com> wrote:

> Hi,
>
> I am getting an error "Cannot use non-message variable "memberRegistration"
> in this context (message variable is required)". I believe however that i
> am
> using an element variable correctly. The WS-BPEL spec states:
> "If the WSDL operation uses a message containing exactly one part which
> itself is defined using an element, then a WS-BPEL variable of the same
> element type as used to define the part MAY be referenced by the
> variableattribute of the
> <receive> or <reply> activity." (see
> http://docs.oasis-open.org/wsbpel/2.0/OS/wsbpel-v2.0-OS.html#SA00058_table
> ).
>
>
> My messages contain one part (ref element) and my variables are of the same
> element type. So i believe it should work.
>
> In this thread: http://markmail.org/message/uyl5ggxeyzol7ylp i see a reply
> that reads "..These activities all need a variable with messageType".
>
> Am i misinterpreting the spec or does ODE not support this (I am using ODE
> 1.2 )?
>

You're not misinterpreting, ODE doesn't support this for now (see the
<invoke> activity in [1]). It's still in our todo list.

Thanks,
Matthieu

[1] http://ode.apache.org/ws-bpel-20-specification-compliance.html



>
> Tx.,
>
> Raphael
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message