ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthieu Riou" <matth...@offthelip.org>
Subject Re: NullPointerException: Null type argument!
Date Mon, 14 Jul 2008 14:29:31 GMT
On Mon, Jul 14, 2008 at 1:34 AM, Massimiliano Giraldo <max.xam1983@gmail.com>
wrote:

>
> Hi all!
>
> I'm a newbie of Apache Ode.
> I have a service working correctly on ActiveBpel and I try to make it work
> on Apache Ode.
>
> When I put the folder of my service in the folder "processes" of Ode, I
> have
> this error:
>
> ERROR - GeronimoLog.error(108) | Deployment of CallOnArrival failed,
> aborting for now.
> java.lang.NullPointerException: Null type argument!
>        at
>
> org.apache.ode.utils.xsd.SchemaModelImpl.isSimpleType(SchemaModelImpl.java:156)
>        at
> org.apache.ode.bpel.compiler.BpelCompiler.compile(BpelCompiler.java:933)
>        at
> org.apache.ode.bpel.compiler.BpelCompiler.compile(BpelCompiler.java:690)
>        at org.apache.ode.bpel.compiler.BpelC.compile(BpelC.java:260)
>        at org.apache.ode.bpel.compiler.BpelC.compile(BpelC.java:330)
>        at
> org.apache.ode.store.DeploymentUnitDir.compile(DeploymentUnitDir.java:162)
>        at
> org.apache.ode.store.DeploymentUnitDir.compile(DeploymentUnitDir.java:126)
>        at
> org.apache.ode.store.ProcessStoreImpl.deploy(ProcessStoreImpl.java:165)
>        at
>
> org.apache.ode.axis2.deploy.DeploymentPoller.check(DeploymentPoller.java:144)
>        at
>
> org.apache.ode.axis2.deploy.DeploymentPoller.access$300(DeploymentPoller.java:55)
>        at
>
> org.apache.ode.axis2.deploy.DeploymentPoller$PollingThread.run(DeploymentPoller.java:188)
>
> This should be an error of .xsd files (I have three .xsd files in the same
> folder of the service).
> How can I see where the deployment stops?
>
> Thanks for every information =)
>

Mmmh yes, the error message is a bit cryptic. I'm going to improve that. The
origin of the error seems to be in a property type definition. We check
whether the types defined for properties are simple types and that's where
resolving fails. So you should check those to make sure the types are
correct,

Cheers,
Matthieu


>
> Cheers
> Max
>
>
> -----
> http://www.pcguide.netsons.org http://www.pcguide.netsons.org
> --
> View this message in context:
> http://www.nabble.com/NullPointerException%3A-Null-type-argument%21-tp18439565p18439565.html
> Sent from the Apache Ode User mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message