ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stelianos G. Sfakianakis" <sgs...@gmail.com>
Subject Re: asynchronous process -> service communication
Date Wed, 02 Jul 2008 14:59:58 GMT
On Wed, Jul 2, 2008 at 5:23 PM, Matthieu Riou <matthieu@offthelip.org> wrote:
> Can you try with the 1.2 we're currently releasing? It's published here for
> now (until the release is final):
>
> http://people.apache.org/~mriou/ode-1.2/org/apache/ode/apache-ode-war/1.2/

Hi Matthieu, that's what I did just before your email. With the same
process definition etc. I sent yesterday I noticed a different
behavior: a selectionFailure for OrderId. This is actually the
correlation property and I found its property aliases in the file
Test2Artifacts.wsdl, which is automatically generated by
Lomboz/EclipseBPEL, where there were the following:

<vprop:propertyAlias messageType="wsdl:HelloWorldRequestMessage"
part="payload" propertyName="tns:OrderId">
        <vprop:query><![CDATA[/OrderId]]></vprop:query>
    </vprop:propertyAlias>
    <vprop:propertyAlias messageType="wsdl:HelloWorldResponseMessage"
part="payload" propertyName="tns:OrderId">
        <vprop:query><![CDATA[/OrderId]]></vprop:query>
    </vprop:propertyAlias>

So what I thought is that the xpath contained in the vprop:query
should include the correct namespace prefix (is that correct?).
Therefore I changed these queries to have "/wsdl:OrderId" instead of
just "/OrderId" (because the ns prefix of the messageType is "wsdl").
You can find the modified file attached.

After this change I get the same error I had with ode 1.1.1
(java.lang.NullPointerException at
org.apache.ode.bpel.engine.MyRoleMessageExchangeImpl.invoke(MyRoleMessageExchangeImpl.java:134)
)

I also tried removing the correlation and using the "implicit
correlation" but the problem persists.

>From http://ssfak.org/temp/Test2.zip you can get the zip of all the
files ready to be deployed (it seems that I can not send the zip as
attachment)

Best regards,
Stelios

Mime
View raw message