ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Boisvert" <boisv...@intalio.com>
Subject Re: Error trying to access external webservice
Date Mon, 14 Jul 2008 06:21:28 GMT
Did you include your WSDL(s) in the BPEL SU as well?

alex


On Sun, Jul 13, 2008 at 10:08 PM, navigator09 <ganeshsurathkal@gmail.com>
wrote:

>
> Hi,
>
>  I am trying to access external webservice from the BPEL process. But when
> i try to deploy the service assembly I get the following error
>
>
> 16:41:38,093 | INFO  | Timer-6    | AutoDeploymentService    |
> ramework.AutoDeploymentService  646 | Directory: hotdeploy: Archive
> changed:
> processing HelloWorld2-sa.zip ...
> 16:41:38,312 | INFO  | Timer-6    | ProcessStoreImpl         |
> eronimo.kernel.log.GeronimoLog   79 | Starting deployment of processes from
> directory
>
> "D:\apache-servicemix-3.2.1\data\smx\service-assemblies\HelloWorld2-SA\version_1\sus\OdeBpelEngine\HelloWorld2-process".
> 16:41:39,203 | INFO  | Timer-6    | BpelC                    |
> eronimo.kernel.log.GeronimoLog   79 | info: [CompilingProcess] Compiling
> BPEL process.
> 16:41:39,359 | WARN  | Timer-6    | BpelC                    |
> eronimo.kernel.log.GeronimoLog   92 | warning: [WsdlUriIgnoredFor20Process]
> Process WSDL URI is ignored for WS-BPEL 2.0 processes.
> 16:41:39,468 | ERROR | Timer-6    | OdeServiceUnit           |
> eronimo.kernel.log.GeronimoLog  108 | Error deploying process described by
> deployment descriptor
>
> "D:\apache-servicemix-3.2.1\data\smx\service-assemblies\HelloWorld2-SA\version_1\sus\OdeBpelEngine\HelloWorld2-process"
> for service unit "HelloWorld2-process".
> java.lang.NullPointerException
>        at
>
> org.apache.ode.bpel.compiler.WSDLRegistry.getPartnerLinkType(WSDLRegistry.java:266)
>        at
>
> org.apache.ode.bpel.compiler.BpelCompiler.resolvePartnerLinkType(BpelCompiler.java:434)
>        at
> org.apache.ode.bpel.compiler.BpelCompiler.compile(BpelCompiler.java:988)
>        at
>
> org.apache.ode.bpel.compiler.BpelCompiler.access$1200(BpelCompiler.java:126)
>        at
> org.apache.ode.bpel.compiler.BpelCompiler$8.run(BpelCompiler.java:1115)
>        at
> org.apache.ode.bpel.compiler.BpelCompiler.compile(BpelCompiler.java:1051)
>        at
>
> org.apache.ode.bpel.compiler.BpelCompiler.compileScope(BpelCompiler.java:1095)
>        at
> org.apache.ode.bpel.compiler.BpelCompiler.compile(BpelCompiler.java:690)
>        at org.apache.ode.bpel.compiler.BpelC.compile(BpelC.java:260)
>        at org.apache.ode.bpel.compiler.BpelC.compile(BpelC.java:330)
>
>
> From the above error message, all i could make out was that there is some
> problem with the deployment descriptor. I am pasting the deployment
> descriptor below.
>
> <deploy xmlns="http://www.apache.org/ode/schemas/dd/2007/03"
>        xmlns:pns="urn:/HelloWorld2.bpel"
>        xmlns:sns="urn:/HelloWorld2.wsdl"
>        xmlns:fewsdl="http://scm">
>
>
>        <process name="pns:HelloWorld2" fileName ="HelloWorld2.bpel"
> bpel11wsdlFileName = "SCMService.wsdl" >
>                <active>true</active>
>                  <provide partnerLink="helloPartnerLink">
>                          <service name="sns:HelloService"
> port="HelloPort"/>
>                  </provide>
>                  <invoke partnerLink="ScmserviceLT">
>                        <service name="fewsdl:SCMServiceService"
> port="SCMService"/>
>                </invoke>
>        </process>
> </deploy>
>
> the servicename and the port number are  mentioned in the wsdl in the http
> su. Please let me know the problem in this case.
>
> Regards,
> Ganesh
> --
> View this message in context:
> http://www.nabble.com/Error-trying-to-access--external-webservice-tp18437562p18437562.html
> Sent from the Apache Ode User mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message