ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From navigator09 <ganeshsurath...@gmail.com>
Subject Compilation problems in apache ode
Date Thu, 10 Jul 2008 07:03:10 GMT

Hi,

I a trying to define a new partner link in in .bpel file and invoke a
existing webservice using it. In the process I have encountered the
following problem.

11:40:00,968 | ERROR | Timer-6    | ProcessStoreImpl         |
eronimo.kernel.log.GeronimoLog  108 | Deploy failed; error:
[CompilationErrors] Compilation completed with 1 error(s):

file:/D:/apache-servicemix-3.2.1/data/smx/service-assemblies/HelloWorld2-SA/version_1/sus/OdeBpelEngine/HelloWorld2-process/HelloWorld2.bpel:44:
error: [UndeclaredPartnerLinkType] Attempt to reference undeclared partner
link type "{http://scm}ScmserviceLT".

org.apache.ode.bpel.compiler.api.CompilationException: error:
[CompilationErrors] Compilation completed with 1 error(s):

file:/D:/apache-servicemix-3.2.1/data/smx/service-assemblies/HelloWorld2-SA/version_1/sus/OdeBpelEngine/HelloWorld2-process/HelloWorld2.bpel:44:
error: [UndeclaredPartnerLinkType] Attempt to reference undeclared partner
link type "{http://scm}ScmserviceLT".


I have cross verified the partner wsdl files and deploy.xml files for the
declaration of the partner link. The partner wsdl containes the following
declaration 

<plnk:partnerLinkType name="tns:ScmserviceLT">
		<plnk:role name="Provider" portType="tns:SCMService" />
  </plnk:partnerLinkType>

and the deployment descriptor 

   
	<process name="pns:HelloWorld2">
		<active>true</active>
		  <provide partnerLink="helloPartnerLink">
			  <service name="sns:HelloService" port="HelloPort"/>
		  </provide>
		  <provide partnerLink="scmservicePL">
			<service name="fewsdl:SCMServiceService" port="SCMService"/>
		</provide>
	</process>
</deploy>


and the partnerlinktype is given below
<partnerLink name="scmservicePL"
                partnerLinkType="fewsdl:ScmserviceLT"
                partnerRole="Provider" />

Please help me out in the problem. I am stuck with it since the last one day

Regards,
Ganesh





-- 
View this message in context: http://www.nabble.com/Compilation-problems-in-apache-ode-tp18377109p18377109.html
Sent from the Apache Ode User mailing list archive at Nabble.com.


Mime
View raw message