ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Coogan <Jonathan.Coo...@attachmate.com>
Subject Re: NPE when using process management WSDL
Date Wed, 18 Jun 2008 16:57:07 GMT
Thanks.  That works great.


On 6/17/08 3:45 PM, "Tammo van Lessen" <tvanlessen@gmail.com> wrote:

> Hi Jonathan,
> 
> the expected serialization of the QName is prefix:localname and the
> prefix should be bound somewhere in the request.
> 
> The following snippet should do the jobs. In any case, a NPE is probably
> not the best way to communicate this... I'm fixing this.
> 
> <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
> xmlns:pmap="http://www.apache.org/ode/pmapi">
>     <soapenv:Header/>
>     <soapenv:Body>
>        <pmap:getProcessInfo>
>           <pid xmlns:pns="abcd">pns:HelloWorld-13</pid>
>        </pmap:getProcessInfo>
>     </soapenv:Body>
> </soapenv:Envelope>
> 
> Best regards,
>    Tammo
> 
> Jonathan Coogan wrote:
>> I¹ve been playing around with the process management service.  I¹m seeing a
>> NullPointerException when I invoke the getProcessInfo operation.
>> 
>> In soapUI, I send this:
>> 
>> <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
>> xmlns:pmap="http://www.apache.org/ode/pmapi">
>>    <soapenv:Header/>
>>    <soapenv:Body>
>>       <pmap:getProcessInfo>
>>          <pid>{abcd}HelloWorld-13</pid>
>>       </pmap:getProcessInfo>
>>    </soapenv:Body>
>> </soapenv:Envelope>
>> 
>> And I get this:
>> 
>> <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
>>    <soapenv:Body>
>>       <soapenv:Fault>
>>          <faultcode>soapenv:Server</faultcode>
>>          <faultstring>java.lang.NullPointerException</faultstring>
>>          <detail>
>>             <axis2ns3:NullPointerException
>> xmlns:axis2ns3="http://www.apache.org/ode/pmapi/types/2006/08/02/">java.lang
>> .NullPointerException
>> at org.apache.ode.il.OMUtils.getTextAsQName(OMUtils.java:211)
>> at org.apache.ode.il.DynamicService.convertFromOM(DynamicService.java:113)
>> at org.apache.ode.il.DynamicService.extractParams(DynamicService.java:97)
>> at org.apache.ode.il.DynamicService.invoke(DynamicService.java:68)
>> at 
>> org.apache.ode.axis2.service.ManagementService$DynamicMessageReceiver.invoke
>> BusinessLogic(ManagementService.java:126)
>> at 
>> org.apache.axis2.receivers.AbstractMessageReceiver.receive(AbstractMessageRe
>> ceiver.java:96)
>> at org.apache.axis2.engine.AxisEngine.receive(AxisEngine.java:145)
>> at 
>> org.apache.axis2.transport.http.HTTPTransportUtils.processHTTPPostRequest(HT
>> TPTransportUtils.java:275)
>> at org.apache.axis2.transport.http.AxisServlet.doPost(AxisServlet.java:120)
>> at javax.servlet.http.HttpServlet.service(HttpServlet.java:760)
>> at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
>> ...
>> </axis2ns3:NullPointerException>
>>          </detail>
>>       </soapenv:Fault>
>>    </soapenv:Body>
>> </soapenv:Envelope>
>> 
>> I'm curious if other people are seeing this as well, or if I'm doing
>> something wrong.  This is with 1.2 RC1 (but also with 1.1.1).
>> 
>> Thanks.
>> -Jon
>> 
> 


Mime
View raw message