ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Boisvert" <boisv...@intalio.com>
Subject Re: "Cannot find definition for service"
Date Fri, 13 Jun 2008 17:15:37 GMT
When I deployed your process, the error I got was more specific than what
you provided:

10:10:47,601 ERROR [DeploymentPoller] Deployment of portal failed, aborting
for now.
org.apache.ode.bpel.iapi.ContextException: Cannot find definition for
service {
http://services.servface.org/AccountManagementFaculty/}AccountManagementFacultyin
the context of process {
http://sample.bpel.org/bpel/sample}Portal-24
    at
org.apache.ode.axis2.BindingContextImpl.createPartnerRoleChannel(BindingContextImpl.java:78)

I fixed it by using the correct service name in deploy.xml:

    <invoke partnerLink="AccountService">
      <service name="ns0:AccountManagementFacultyService"
port="AccountManagementFaculty"/>
    </invoke>

(Instead of "ns0:AccountManagementFaculty")

alex


On Fri, Jun 13, 2008 at 10:00 AM, Johannes Waltsgott <
jwaltsgott@googlemail.com> wrote:

> Hi Alex,
>
> here's my BPEL file:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <bpws:process exitOnStandardFault="yes" name="Portal"
>    suppressJoinFailure="yes"
>    targetNamespace="http://sample.bpel.org/bpel/sample"
>    xmlns:bpws="http://docs.oasis-open.org/wsbpel/2.0/process/executable"
>    xmlns:ns="http://sample.bpel.org/bpel/sampleArtifacts"
>    xmlns:ns0="http://services.servface.org/AccountManagementFaculty/"
> xmlns:tns="http://sample.bpel.org/bpel/sample">
>    <bpws:import importType="http://schemas.xmlsoap.org/wsdl/"
>        location="Portal.wsdl"
> namespace="http://sample.bpel.org/bpel/sample"/>
>    <!-- <bpws:import importType="http://schemas.xmlsoap.org/wsdl/"
>        location="AccountManagementFaculty.wsdl"
> namespace="http://services.servface.org/AccountManagementFaculty/"/> -->
>    <bpws:import importType="http://schemas.xmlsoap.org/wsdl/"
>        location="PortalArtifacts.wsdl"
> namespace="http://sample.bpel.org/bpel/sampleArtifacts"/>
>    <bpws:partnerLinks>
>        <bpws:partnerLink myRole="PortalProvider" name="client"
> partnerLinkType="tns:Portal"/>
>        <bpws:partnerLink name="AccountService"
>            partnerLinkType="ns:AccountServicePLT"
> partnerRole="AccountServiceProvider"/>
>    </bpws:partnerLinks>
>    <bpws:variables>
>        <bpws:variable messageType="tns:PortalRequestMessage" name="input">
>            <bpws:from endpointReference="myRole" partnerLink="client"/>
>        </bpws:variable>
>        <bpws:variable messageType="tns:PortalResponseMessage"
> name="output">
>            <bpws:from endpointReference="myRole" partnerLink="client"/>
>        </bpws:variable>
>        <bpws:variable messageType="ns0:getIdResponse"
> name="AccountServiceResponse">
>            <bpws:from endpointReference="partnerRole"
> partnerLink="AccountService"/>
>        </bpws:variable>
>        <bpws:variable messageType="ns0:getIdRequest"
> name="AccountServiceRequest">
>            <bpws:from endpointReference="partnerRole"
> partnerLink="AccountService"/>
>        </bpws:variable>
>    </bpws:variables>
>    <bpws:sequence name="main">
>        <bpws:receive createInstance="yes" name="receiveInput"
>            operation="process" partnerLink="client"
>            portType="tns:Portal" variable="input"/>
>        <bpws:assign name="Assign" validate="no">
>            <bpws:copy>
>                <bpws:from part="payload" variable="input">
>                    <bpws:query
>
> queryLanguage="urn:oasis:names:tc:wsbpel:2.0:sublang:xpath1.0"><![CDATA[/tns
> :input]]></bpws:query>
>                </bpws:from>
>                <bpws:to part="parameters" variable="AccountServiceRequest">
>                    <bpws:query
>
> queryLanguage="urn:oasis:names:tc:wsbpel:2.0:sublang:xpath1.0"><![CDATA[/log
> in]]></bpws:query>
>                </bpws:to>
>            </bpws:copy>
>        </bpws:assign>
>        <bpws:invoke inputVariable="AccountServiceRequest" name="Invoke"
>            operation="getId" outputVariable="AccountServiceResponse"
>            partnerLink="AccountService"
> portType="ns0:AccountManagementFaculty"/>
>        <bpws:assign name="Assign1" validate="no">
>            <bpws:copy>
>                <bpws:from part="parameters"
> variable="AccountServiceResponse">
>                    <bpws:query
>
> queryLanguage="urn:oasis:names:tc:wsbpel:2.0:sublang:xpath1.0"><![CDATA[/id]
> ]></bpws:query>
>                </bpws:from>
>                <bpws:to part="payload" variable="output">
>                    <bpws:query
>
> queryLanguage="urn:oasis:names:tc:wsbpel:2.0:sublang:xpath1.0"><![CDATA[/tns
> :id]]></bpws:query>
>                </bpws:to>
>            </bpws:copy>
>        </bpws:assign>
>        <bpws:reply name="replyOutput" operation="process"
>            partnerLink="client" portType="tns:Portal" variable="output"/>
>    </bpws:sequence>
> </bpws:process>
>
> Joe
>
>
> > Hi Johannes,
> >
> > Could you also include your BPEL file?
> >
> > alex
> >
> >
> > On Fri, Jun 13, 2008 at 8:17 AM, Johannes Waltsgott <
> > jwaltsgott@googlemail.com> wrote:
> >
> > >  Hi all,
> > >
> > > I'm new to BPEL and ODE and I'm trying to get a simple BPEL
> > processrunningwhich invok
> > > es an existing web service. When deploying the BPEL process to ODE,
> > I'm
> > > getting the error
> > >
> > > "Cannot find definition of process {
> > >
> > http://services.servface.org/AccountManagementFaculty/}AccountManagemen<http://services.servface.org/AccountManagementFaculty/%7DAccountManagemen>
> > tFaculty
> > > in the context of process
> > {http://sample.bpel.org/bpel/sample}Portal<http://sample.bpel.org/bpel/sample%7DPortal>
> <http://sample.bpel.org/bpel/
> > sample%7DPortal>
> > >
> > > I'm using Eclipse BPEL Designer, ODE 1.2RC1 (same with ODE 1.1.1,
> > too),
> > > Tomcat 6.
> > >
> > > I just found some older conversation on this topic, but its solution
> > didn't
> > > works for me - there was an import of the wsdl of the web service in
> > the
> > > Eclipse generate {Projectname}Artifacts.wsdl which ODE couldn't
> > resolve. I
> > > 've copied the imported wsdl of the web service to the project folder
> > and
> > > changed the import reference in the Artifacts.wsdl to that direct
> > > reference.
> > >
> > > Please find the files attached, does anybody could give me a hint?
> > >
> > > Thanks very much in advance!
> > >
> > > Joe
> > >
> > >  <<...>> <<...>> <<...>> <<...>>
<<...>>
> > >
> > >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message