ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthieu Riou" <matth...@offthelip.org>
Subject Re: Deployment failed within the engine, store undeploying process
Date Mon, 05 May 2008 14:56:00 GMT
Some description of what you're trying to do would probably help but if I
have to do some guesswork I'd think your port declaration in deploy.xml
doesn't match the port of your WSDL service ("Couldn't find port
myservicePort in definition
{http://www.me.com/service.wsdl}myserviceService<http://www.me.com/service.wsdl%7DmyserviceService>
").

Cheers,
Matthieu

On Mon, May 5, 2008 at 12:58 AM, Tariq Rafique <brb_pk@yahoo.com> wrote:

>  DEBUG - GeronimoLog.debug(66) | Process store event:
> {ProcessStoreEvent#DEPLOYED:{http://www.me.com/service.bpel}myservice-38<http://www.me.com/service.bpel%7Dmyservice-38>
> }
>  DEBUG - GeronimoLog.debug(66) | Ignoring store event:
> {ProcessStoreEvent#DEPLOYED:{http://www.me.com/service.bpel}myservice-38<http://www.me.com/service.bpel%7Dmyservice-38>
> }
>  DEBUG - GeronimoLog.debug(66) | Process store event:
> {ProcessStoreEvent#ACTVIATED:{http://www.me.com/service.bpel}myservice-38<http://www.me.com/service.bpel%7Dmyservice-38>
> }
>  DEBUG - GeronimoLog.debug(66) | register: {
> http://www.me.com/service.bpel}myservice-38<http://www.me.com/service.bpel%7Dmyservice-38>
>  DEBUG - GeronimoLog.debug(66) | Registering process {
> http://www.me.com/service.bpel}myservice-38<http://www.me.com/service.bpel%7Dmyservice-38>with
>  server.
>  DEBUG - GeronimoLog.debug(66) | Register process: serviceId={
> http://www.me.com/service.wsdl}myserviceS<http://www.me.com/service.wsdl%7DmyserviceS>
>  ervice:myservicePort, process=BpelProcess[{
> http://www.me.com/service.bpel}myservice-38<http://www.me.com/service.bpel%7Dmyservice-38>
> ]
>  DEBUG - GeronimoLog.debug(66) | Activating {
> http://www.me.com/service.bpel}myservice-38<http://www.me.com/service.bpel%7Dmyservice-38>
>  DEBUG - GeronimoLog.debug(66) | Destroying service {
> http://www.me.com/service.wsdl}myserviceService<http://www.me.com/service.wsdl%7DmyserviceService>po
>  rt myservicePort
>  DEBUG - GeronimoLog.debug(66) | Couldn't find service {
> http://www.me.com/service.wsdl}myserviceService<http://www.me.com/service.wsdl%7DmyserviceService>
>  port myservicePort to destroy.
>  WARN - GeronimoLog.warn(92) | Deployment failed within the engine, store
> undeploying process.
>  DEBUG - GeronimoLog.debug(66) | Process store event:
> {ProcessStoreEvent#UNDEPLOYED:{http://www.me.com/service.bpel}myservice-38<http://www.me.com/service.bpel%7Dmyservice-38>
> }
>  DEBUG - GeronimoLog.debug(66) | Deactivating process {
> http://www.me.com/service.bpel}myservice-38<http://www.me.com/service.bpel%7Dmyservice-38>
>  INFO - GeronimoLog.info(79) | Unregistered process {
> http://www.me.com/service.bpel}myservice-38<http://www.me.com/service.bpel%7Dmyservice-38>
> .
>  ERROR - GeronimoLog.error(108) | Deployment of myservice failed, aborting
> for now.
>  org.apache.ode.bpel.iapi.ContextException: Could not activate endpoint
> for myservice {http://www.me.com/service.wsdl}myserviceService<http://www.me.com/service.wsdl%7DmyserviceService>and
port myservicePort
>  at
> org.apache.ode.axis2.BindingContextImpl.activateMyRoleEndpoint(BindingContextImpl.java:62)
>  at org.apache.ode.bpel.engine.BpelProcess.activate(BpelProcess.java:500)
>  at
> org.apache.ode.bpel.engine.BpelEngineImpl.registerProcess(BpelEngineImpl.java:232)
>  at
> org.apache.ode.bpel.engine.BpelServerImpl.register(BpelServerImpl.java:282)
>  at org.apache.ode.axis2.ODEServer.handleEvent(ODEServer.java:543)
>  at org.apache.ode.axis2.ODEServer.access$100(ODEServer.java:73)
>  at
> org.apache.ode.axis2.ODEServer$ProcessStoreListenerImpl.onProcessStoreEvent(ODEServer.java:529)
>  at
> org.apache.ode.store.ProcessStoreImpl.fireEvent(ProcessStoreImpl.java:501)
>  at
> org.apache.ode.store.ProcessStoreImpl.fireStateChange(ProcessStoreImpl.java:507)
>  at
> org.apache.ode.store.ProcessStoreImpl.deploy(ProcessStoreImpl.java:284)
>  at
> org.apache.ode.axis2.deploy.DeploymentPoller.check(DeploymentPoller.java:144)
>  at
> org.apache.ode.axis2.deploy.DeploymentPoller.access$300(DeploymentPoller.java:55)
>  at
> org.apache.ode.axis2.deploy.DeploymentPoller$PollingThread.run(DeploymentPoller.java:188)
>  Caused by: org.apache.ode.axis2.OdeFault: Couldn't find port
> myservicePort in definition {
> http://www.me.com/service.wsdl}myserviceService<http://www.me.com/service.wsdl%7DmyserviceService>
>  at
> org.apache.ode.axis2.hooks.ODEAxisService.extractServiceName(ODEAxisService.java:148)
>  at
> org.apache.ode.axis2.hooks.ODEAxisService.createService(ODEAxisService.java:60)
>  at org.apache.ode.axis2.ODEServer.createService(ODEServer.java:306)
>  at
> org.apache.ode.axis2.BindingContextImpl.activateMyRoleEndpoint(BindingContextImpl.java:59)
>
>
> ---------------------------------
> Be a better friend, newshound, and know-it-all with Yahoo! Mobile.  Try it
> now.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message