ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pablo lagartijo <pablo_lagart...@hotmail.com>
Subject RE: Maven2 conf. for Eclipse (Building ODE)
Date Thu, 29 May 2008 20:53:05 GMT

Starting Eclipse with:

eclipse -vm "c:\Program Files\Java\jdk1.5.0_15\bin\java"

It works !!! I don't have messages in the Eclipse console.

Thanks a lot.



> Date: Thu, 29 May 2008 11:43:23 -0700
> From: boisvert@intalio.com
> To: user@ode.apache.org
> Subject: Re: Maven2 conf. for Eclipse (Building ODE)
>
> You probably need to point your JAVA_HOME environment variable to a JDK, or
> start Eclipse with an explicit path to your JDK...
>
> eclipse -vm /path/to/your//jdk1.6.0_04/bin/java
>
> alex
>
>
> On Thu, May 29, 2008 at 11:33 AM, pablo lagartijo <
> pablo_lagartijo@hotmail.com> wrote:
>
>>
>> Indeed, it was no pointing to the Maven2 repository.
>> Now I don't have errors, only Warnings (but I suppose that is not
>> important).
>>
>> However, I continue have the following message on the console:
>>
>> 29/05/08 19:58:51 CEST: Eclipse is running in a JRE, but a JDK is required
>> Some Maven plugins may not work when importing
>> projects or updating source folders.
>> 29/05/08 19:58:56 CEST: Downloading central :
>> nexus-maven-repository-index.properties
>> 29/05/08 19:58:56 CEST: Downloaded [central] ->
>> http://repo1.maven.org/maven2/.index/nexus-maven-repository-index.properties
>> 29/05/0819:58:56 CEST: No index update available for central
>>
>> (
>> I have installed in Eclipse (Window -> Preference -> Java -> Installed
>> JREs):
>> jre1.5.0_15 (Selected)
>> jdk1.5.0_15 (If I select this I have the same error message)
>> )
>>
>> any idea?
>>
>> Pablo.
>>
>>
>>
>>> Date: Thu, 29 May 2008 08:53:12 -0700
>>> From: boisvert@intalio.com
>>> To: user@ode.apache.org
>>> Subject: Re: Maven2 conf. for Eclipse (Building ODE)
>>>
>>> Just a guess; you might want to double-check that your M2_REPO build
>>> variable (in Eclipse) points to the root of your Maven2 repository.
>>>
>>> alex
>>>
>>>
>>> On Thu, May 29, 2008 at 3:47 AM, pablo lagartijo <
>>> pablo_lagartijo@hotmail.com> wrote:
>>>
>>>>
>>>>
>>>> Hello everyone,
>>>>
>>>> I downloaded the ODE source code from the web page
>> (apache-ode-src-1.1.zip)
>>>> and I have executed the commands:
>>>> "not rake TEST = ode: package" and
>>>> "rake eclipse".
>>>>
>>>> After that I imported the project to Eclipse, reporting the following
>>>> errors:
>>>>
>>>>
>>>> Eclipse Problems (291):
>>>> Project 'ode-axis2-war' is missing required library:
>>>> 'C:\apache-maven-2.0.9\jmock\jmock\1.2.0\jmock-1.2.0.jar'
>>>> Project 'ode-axis2-war' is missing required library:
>>>> 'C:\apache-maven-2.0.9\junit\junit\4.3.1\junit-4.3.1.jar'
>>>> ...
>>>> ...
>>>> ...
>>>> Project 'ode-bpel-runtime' is missing required library:
>>>> 'C:\apache-maven-2.0.9\stax\stax-api\1.0.1\stax-api-1.0.1.jar'
>>>>
>>>>
>>>> Eclipse console:
>>>> 29/05/08 12:18:20 CEST: [INFO] User settings file does not exist
>>>> C:\Documents and Settings\Lagartijo\.m2\settings.xml
>>>> 29/05/08 12:18:27 CEST: Eclipse is running in a JRE, but a JDK is
>> required
>>>> Some Maven plugins may not work when importing projects or updating
>> source
>>>> folders.
>>>> 29/05/08 12:18:28 CEST: [INFO] User settings file does not exist
>>>> C:\Documents and Settings\Lagartijo\.m2\settings.xml
>>>> 29/05/08 12:18:32 CEST: Downloading central :
>>>> nexus-maven-repository-index.properties
>>>> 29/05/08 12:18:32 CEST: Downloaded [central] ->
>>>>
>> http://repo1.maven.org/maven2/.index/nexus-maven-repository-index.properties
>>>> 29/05/0812:18:32 CEST: No index update available for central
>>>>
>>>> I suppose they are erros by a bad installation/configuration of Maven2
>> in
>>>> windows and in eclipse.
>>>> If someone could tell me the next steps I would be very grateful.
>>>>
>>>> (
>>>> WindowsXP Prof,
>>>> Java JDK 1.5.0_15,
>>>> Apache-Maven 2.0.9,
>>>> Ecplise 3.3.2,
>>>>
>>>> CLASSPATH = C:\Archivos de programa\Java\jdk1.5.0_15\lib
>>>> JAVA_HOME = C:\Archivos de programa\Java\jdk1.5.0_15
>>>> M2_HOME = C:\apache-maven-2.0.9
>>>> PATH = C:\ruby\bin;
>>>> C:\apache-maven-2.0.9\bin;
>>>> C:\Archivos de programa\Java\jdk1.5.0_15\bin;
>>>> C:\apache-ant-1.7.0\bin;
>>>> C:\Subversion\bin;
>>>> C:\apache-maven-2.0.9\bin
>>>> )
>>>>
>>>>
>>>> Thank you in advance,
>>>> Pablo.
>>>> _________________________________________________________________
>>>> MSN Video.
>>>> http://video.msn.com/?mkt=es-es
>>>>
>>
>> _________________________________________________________________
>> MSN Video.
>> http://video.msn.com/?mkt=es-es
>>

_________________________________________________________________
MSN Noticias
http://noticias.msn.es/comunidad.aspx
Mime
View raw message