ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Boisvert" <boisv...@intalio.com>
Subject Re: Maven2 conf. for Eclipse (Building ODE)
Date Thu, 29 May 2008 15:53:12 GMT
Just a guess; you might want to double-check that your M2_REPO build
variable (in Eclipse) points to the root of your Maven2 repository.

alex


On Thu, May 29, 2008 at 3:47 AM, pablo lagartijo <
pablo_lagartijo@hotmail.com> wrote:

>
>
> Hello everyone,
>
> I downloaded the ODE source code from the web page (apache-ode-src-1.1.zip)
> and I have executed the commands:
> "not rake TEST = ode: package" and
> "rake eclipse".
>
> After that I imported the project to Eclipse, reporting the following
> errors:
>
>
> Eclipse Problems (291):
> Project 'ode-axis2-war' is missing required library:
> 'C:\apache-maven-2.0.9\jmock\jmock\1.2.0\jmock-1.2.0.jar'
> Project 'ode-axis2-war' is missing required library:
> 'C:\apache-maven-2.0.9\junit\junit\4.3.1\junit-4.3.1.jar'
> ...
> ...
> ...
> Project 'ode-bpel-runtime' is missing required library:
> 'C:\apache-maven-2.0.9\stax\stax-api\1.0.1\stax-api-1.0.1.jar'
>
>
> Eclipse console:
> 29/05/08 12:18:20 CEST: [INFO] User settings file does not exist
> C:\Documents and Settings\Lagartijo\.m2\settings.xml
> 29/05/08 12:18:27 CEST: Eclipse is running in a JRE, but a JDK is required
>  Some Maven plugins may not work when importing projects or updating source
> folders.
> 29/05/08 12:18:28 CEST: [INFO] User settings file does not exist
> C:\Documents and Settings\Lagartijo\.m2\settings.xml
> 29/05/08 12:18:32 CEST: Downloading central :
> nexus-maven-repository-index.properties
> 29/05/08 12:18:32 CEST: Downloaded [central] ->
> http://repo1.maven.org/maven2/.index/nexus-maven-repository-index.properties
> 29/05/08<http://repo1.maven.org/maven2/.index/nexus-maven-repository-index.properties29/05/08>12:18:32
CEST: No index update available for central
>
> I suppose they are erros by a bad installation/configuration of Maven2 in
> windows and in eclipse.
> If someone could tell me the next steps I would be very grateful.
>
> (
> WindowsXP Prof,
> Java JDK 1.5.0_15,
> Apache-Maven 2.0.9,
> Ecplise 3.3.2,
>
> CLASSPATH = C:\Archivos de programa\Java\jdk1.5.0_15\lib
> JAVA_HOME = C:\Archivos de programa\Java\jdk1.5.0_15
> M2_HOME = C:\Documents and Settings\Lagartijo\.m2
> PATH = C:\ruby\bin;
>            C:\apache-maven-2.0.9\bin;
>            C:\Archivos de programa\Java\jdk1.5.0_15\bin;
>            C:\apache-ant-1.7.0\bin;
>            C:\Subversion\bin;
>            C:\apache-maven-2.0.9\bin
> )
>
>
> Thank you in advance,
> Pablo.
> _________________________________________________________________
> MSN Video.
> http://video.msn.com/?mkt=es-es
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message