ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthieu Riou" <matth...@offthelip.org>
Subject Re: Process Won't List
Date Mon, 31 Mar 2008 23:45:27 GMT
Hi Adam,

That's pretty strange, you don't seem to have any error or exception at
deployment. Does your process declare any <provide> element in your
deploy.xml ? I don't have anything else that could give you that type of
behavior on top of my head, so if it's not a missing <provide> I'd create a
Jira issue and attach your process to it. That way I can have a look at the
whole thing and see what's wrong.

Cheers,
Matthieu

On 3/31/08, Adam Nowak <anowak@idcor.com> wrote:
>
> Good Afternoon,
>
> I have created a BPEL process called helloProcess. The process calls a
> web-service which takes no parameters and returns the string "Hello".
> Every time I go to deploy the process, a .cbp file is generated, however
> helloProcess does not show up in my ODE Process list
> (http://localhost:8080/ode/services/listServices).
>
> Here is the output of my stdout log for Tomcat:
> DEBUG - GeronimoLog.debug(66) | Process store event:
> {ProcessStoreEvent#DEPLOYED:{http://service.idcor.src}helloParamProcess-32
> }
> DEBUG - GeronimoLog.debug(66) | Ignoring store event:
> {ProcessStoreEvent#DEPLOYED:{http://service.idcor.src}helloParamProcess-32
> }
> DEBUG - GeronimoLog.debug(66) | Process store event:
> {ProcessStoreEvent#ACTVIATED:{
> http://service.idcor.src}helloParamProcess-32}
> DEBUG - GeronimoLog.debug(66) | register:
> {http://service.idcor.src}helloParamProcess-32
> DEBUG - GeronimoLog.debug(66) | Registering process
> {http://service.idcor.src}helloParamProcess-32 with server.
> DEBUG - GeronimoLog.debug(66) | Activating
> {http://service.idcor.src}helloParamProcess-32
> DEBUG - GeronimoLog.debug(66) | Activated
> {http://service.idcor.src}helloParamProcess-32
> DEBUG - GeronimoLog.debug(66) | Rehydrating process
> {http://service.idcor.src}helloParamProcess-32
> DEBUG - GeronimoLog.debug(66) | Processing <invoke> element for process
> {http://service.idcor.src}helloParamProcess-32: partnerlink
> helloPartnerLink -->
> {http://service.idcor.src}helloService:helloServiceSOAP11port_http
> DEBUG - GeronimoLog.debug(66) | Setting external service with empty
> namespace replication
> DEBUG - GeronimoLog.debug(66) | Created external service
> {http://service.idcor.src}helloService
> DEBUG - GeronimoLog.debug(66) | Activated
> {http://service.idcor.src}helloParamProcess-32 partnerrole
> helloPartnerLink: EPR is org.apache.ode.bpel.epr.WSAEndpoint@1a5ba75
> DEBUG - GeronimoLog.debug(66) | Creating process DAO for
> {http://service.idcor.src}helloParamProcess-32(guid=hqejbhcnphr35qs4ifkfq4)
> INFO - GeronimoLog.info(79) | Registered process
> {http://service.idcor.src}helloParamProcess-32.
> INFO - GeronimoLog.info(79) | Deployment of artifact bpelTest
> successful: [{http://service.idcor.src}helloParamProcess-32]
>
> PS. I am new to BPEL + Apache ODE so any help would be greatly
> appreciated.
>
> Cheers!
>
> ~Adam
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message