ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthieu Riou" <matth...@offthelip.org>
Subject Re: Ode Version
Date Sat, 01 Mar 2008 20:33:45 GMT
Hi Simone,

The first fix you mention is in 1.1.1 so you shouldn't need to compile from
source. However I doubt your problem is related. Your partner link types
look weird to me:

<plnk:partnerLinkType name="echoInPLT">
    <plnk:role name="read" portType="echoInPT"/>
    <plnk:role name="write" portType="echoInPT"/>
</plk:partnerLinkType>

<plnk:partnerLinkType name="echoOutPLT">
    <plnk:role name="write" portType="echoOutPT"/>
    <plnk:role name="read" portType="echoOutPT"/>
</plk:partnerLinkType>
The myRole and partnerRole (that you named read and write) shouldn't point
to the same portType, unless you want the process to call itself. Have a
look at the MagicSession sample [1] if you want to see how async (one-way
invoke with receive) communication between two processes would work.

Cheers,
Matthieu

On Sat, Mar 1, 2008 at 2:33 AM, Simone Maletta <simonemaletta@alice.it>
wrote:

> Hi guys,
>    I read this Nabble:
> http://www.mail-archive.com/commits@ode.apache.org/msg00239.html
> and I can't compile ODE source from scratch because my Linux distribution
> has got some connection problem and I miss some package.
> Well is there an Ode version that patch this error?
> I think this is the node of my problems, I send a mail yet,
>
> http://markmail.org/message/23t6l3vtgibdrbjg#query:+page:1+mid:zzzowywiovehhh6z+state:results
> Is there anyone that may help me?
> Is this the solution or there is anyone else?
> Thank you,
> Simone

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message