ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Fielenbach <thomasfielenb...@gmx.de>
Subject Internal Server Error by axis2 in Apache ODE
Date Thu, 06 Mar 2008 12:22:58 GMT
Hello,
at the moment I am trying to install (more precisely run) Apache ODE in 
a Tomcat Servlet.

First my configuration:
java 1.5
tomcat 5.5.23
apache ode 1.1.1 (ode.war deployed to $CATALINA_HOME/webapps)

Installation in the servlet container works fine but trying to access the
/http://localhost:8080/ode/axis2-admin// - Page fails in a "Internal 
Server Error.

Validation of axis2 (http://localhost:8080/ode/axis2-web/HappyAxis.jsp) 
shows:

/Examining webapp configuration

    Essential Components
    Found Apache-Axis (org.apache.axis2.transport.http.AxisServlet)
      at /opt/tomcat_5.5/webapps/ode/WEB-INF/lib/axis2-kernel-1.3.jar
    Found Jakarta-Commons Logging (org.apache.commons.logging.Log)
      at /opt/tomcat_5.5/bin/commons-logging-api.jar
    Found Streaming API for XML (javax.xml.stream.XMLStreamReader)
      at /opt/tomcat_5.5/webapps/ode/WEB-INF/lib/stax-api-1.0.1.jar
    Found Streaming API for XML implementation 
(org.codehaus.stax2.XMLStreamWriter2)
      at /opt/tomcat_5.5/webapps/ode/WEB-INF/lib/wstx-asl-3.2.1.jar

    The core axis2 libraries are present.

    Note: Even if everything this page probes for is present, there is 
no guarantee your Axis Service will work, because there are many 
configuration options that we do not check for. These tests are 
necessary but not sufficient

Examining Version Service

There was a problem in Axis2 version service , may be the service not 
available or some thing has gone wrong. But this does not mean system is 
not working ! Try to upload some other service and check to see whether 
it is working.
Examining Application Server

    Servlet version 2.4
    Platform Apache Tomcat/5.5.23
/

Installing axis2 (Version 1.2) in the Servlet Container (deployment of 
axis2.war in $CATALINA_HOME/webapps) works fine. Validation of axis2 
shows that all is ok and I can call the admin-page.


Moreover the http://localhost:8080/ode/services/listServices is 
callable. Available services are:
-Version
- DeploymentService
- InstanceManagement
-ProcessManagement

But trying to call the EPR (for example: 
http://localhost:8080/ode/processes/Version) returns the following failure:
org.apache.axis2.AxisFault: The endpoint reference (EPR) for the 
Operation not found is //ode/processes/Version and the WSA Action = null
        at 
org.apache.axis2.engine.DispatchPhase.checkPostConditions(DispatchPhase.java:86) 

        at org.apache.axis2.engine.Phase.invoke(Phase.java:308)
        at org.apache.axis2.engine.AxisEngine.invoke(AxisEngine.java:212)
        at org.apache.axis2.engine.AxisEngine.receive(AxisEngine.java:132)
        at 
org.apache.axis2.transport.http.util.RESTUtil.invokeAxisEngine(RESTUtil.java:125) 

        at 
org.apache.axis2.transport.http.util.RESTUtil.processURLRequest(RESTUtil.java:119) 

        at 
org.apache.axis2.transport.http.AxisServlet$RestRequestProcessor.processURLRequest(AxisServlet.java:799)


        at 
org.apache.axis2.transport.http.AxisServlet.doGet(AxisServlet.java:242)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:690)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
        at 
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)


        at 
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)


        at 
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:210) 

        at 
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:174) 

        at 
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127) 

        at 
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117) 

        at 
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108) 

        at 
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151)
        at 
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:870)
        at 
org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:665)


        at 
org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:528) 

        at 
org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:81)


        at 
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:685) 

        at java.lang.Thread.run(Thread.java:595)/

Attached is the catalina.out file ( the relevant part of it)

I don't know where the failure lies. Do I have to change the web.xml or 
axis2.xml to solve the problem?

best regards
tmf

Mime
View raw message