ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From patrosk <sunita_pa...@rediffmail.com>
Subject Re: problem in delpoying BPEL service unit on ODE-JBI, servicemix
Date Mon, 17 Mar 2008 12:41:32 GMT

HI..i guess you may need my BpelService.wsdl. here iit is,

<?xml version="1.0" encoding="UTF-8" ?> 
<wsdl:definitions xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
xmlns:tns="http://www.example.org/BpelService/"
xmlns:mime="http://schemas.xmlsoap.org/wsdl/mime/"
xmlns:soap12="http://schemas.xmlsoap.org/wsdl/soap12/"
xmlns:http="http://schemas.xmlsoap.org/wsdl/http/"
xmlns:wsaw="http://www.w3.org/2006/05/addressing/wsdl"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
xmlns:smix="http://servicemix.org/wsdl/jbi/"
targetNamespace="http://www.example.org/BpelService/">
<wsdl:types>
<xsd:schema attributeFormDefault="unqualified"
elementFormDefault="unqualified"
targetNamespace="http://www.example.org/BpelService/">
  <xsd:element name="outputResponse" type="xsd:string" /> 
  <xsd:element name="inputRequest" type="tns:AssignTask" /> 
<xsd:complexType name="AssignTask">
<xsd:sequence>
  <xsd:element name="s1" type="xsd:string" /> 
  <xsd:element name="s2" type="xsd:string" /> 
  </xsd:sequence>
  </xsd:complexType>
  </xsd:schema>
  </wsdl:types>
<wsdl:message name="inputRequest">
  <wsdl:part name="inputRequest" element="tns:inputRequest" /> 
  </wsdl:message>
<wsdl:message name="outputResponse">
  <wsdl:part name="outputResponse" element="tns:outputResponse" /> 
  </wsdl:message>
<wsdl:portType name="BpelServiceSOAPPortType">
<wsdl:operation name="submitjob">
  <wsdl:input message="tns:inputRequest"
wsaw:Action="http://www.example.org/BpelService/submitjob" /> 
  <wsdl:output message="tns:outputResponse"
wsaw:Action="http://www.example.org/BpelService/BpelService/submitjobResponse"
/> 
  </wsdl:operation>
  </wsdl:portType>
<wsdl:binding name="BpelServiceSOAPSOAP11Binding"
type="tns:BpelServiceSOAPPortType">
  <soap:binding transport="http://schemas.xmlsoap.org/soap/http"
style="document" /> 
<wsdl:operation name="submitjob">
  <soap:operation soapAction="http://www.example.org/BpelService/submitjob"
style="document" /> 
<wsdl:input>
  <soap:body use="literal" /> 
  </wsdl:input>
<wsdl:output>
  <soap:body use="literal" /> 
  </wsdl:output>
  </wsdl:operation>
  </wsdl:binding>
<wsdl:service name="BpelServiceSOAP">
<wsdl:port name="BpelServiceSOAPSOAP11port_http"
binding="tns:BpelServiceSOAPSOAP11Binding">
  <soap:address location="http://localhost:8080/BpelServiceSOAP" /> 
 <!-- Connect this external HTTP endpoint to the process internal 
                     JBI endpoint defined in dd -->
    <smix:endpoint role="consumer" defaultMep="in-out"/>
  </wsdl:port>

  </wsdl:service>
  
  </wsdl:definitions>


patrosk wrote:
> 
> Hi, 
> 
> I have a bpel process running, in ODE WAR, hosted on tomcat. 
> I want to deploy the same process, on ODE -JBI on servicemix3.1.1. 
> 
> I have created 2 service units, 1 service unit contains, the .bpel,
> .wsdl's, deploy.xml, i want to deploy the bpel process as http endpoint.
> so i have one more http service unit, which contains only the wsdl, that
> describes the bpel service. 
> 
> package structure, 
> 1. BpelService-process-su.zip(BpelService.wsdl, SimpleService.wsdl,
> BpelService.bpel, deploy.xml) 
> 2.BpelService-http-su.zip(BpelService.wsdl (added smix endpoint here)) 
> 3.meta-inf/jbi.xml 
> So zipped together, the bpel service unit, http service unit and the
> meta-inf/jbi.xml as BpelService-sa.zip and copied to deploy folder of
> servicemix. 
> But i am facing the following deployment issue, 
> 
> INFO  - AutoDeploymentService          - Directory: deploy: Archive
> changed: processing BpelService- 
> sa.zip ... 
> ERROR - OdeServiceUnit                 - Error deploying process described
> by deployment descriptor 
> "E:\servicemix\apache-servicemix-3.1.1-incubating\data\smx\service-assemblies\BpelService-SA\version

> _7\sus\OdeBpelEngine\BpelService-process" for service unit
> "BpelService-process". 
> java.lang.IllegalArgumentException: Directory
> E:\servicemix\apache-servicemix-3.1.1-incubating\data\ 
> smx\service-assemblies\BpelService-SA\version_7\sus\OdeBpelEngine\BpelService-process
> does not conta 
> in a deploy.xml file! 
>         at
> org.apache.ode.store.DeploymentUnitDir.<init>(DeploymentUnitDir.java:103) 
>         at
> org.apache.ode.store.ProcessStoreImpl.deploy(ProcessStoreImpl.java:163) 
>         at
> org.apache.ode.jbi.OdeServiceUnit.deploy(OdeServiceUnit.java:62) 
>         at org.apache.ode.jbi.OdeSUManager.deploy(OdeSUManager.java:60) 
>         at
> org.apache.servicemix.jbi.framework.DeploymentService.deployServiceAssembly(DeploymentSer

> vice.java:527) 
>         at
> org.apache.servicemix.jbi.framework.AutoDeploymentService.updateArchive(AutoDeploymentSer

> vice.java:335) 
>         at
> org.apache.servicemix.jbi.framework.AutoDeploymentService.monitorDirectory(AutoDeployment

> Service.java:646) 
>         at
> org.apache.servicemix.jbi.framework.AutoDeploymentService.access$200(AutoDeploymentServic

> e.java:62) 
>         at
> org.apache.servicemix.jbi.framework.AutoDeploymentService$1.run(AutoDeploymentService.jav

> a:609) 
>         at java.util.TimerThread.mainLoop(Timer.java:512) 
>         at java.util.TimerThread.run(Timer.java:462) 
> ERROR - OdeSUManager                   - Error deploying service unit
> "BpelService-process". 
> INFO  - DeploymentService              - UnDeployed ServiceUnit
> BpelService-process from Component: 
> OdeBpelEngine 
> ERROR - AutoDeploymentService          - Failed to update Service
> Assembly: BpelService-SA 
> java.lang.Exception: <?xml version="1.0" encoding="UTF-8"?> 
> <jbi-task xmlns="http://java.sun.com/xml/ns/jbi/management-message"
> version="1.0"> 
> <jbi-task-result> 
> <frmwk-task-result> 
> <frmwk-task-result-details> 
> <task-result-details> 
> <task-id>deploy</task-id> 
> <task-result>FAILED</task-result> 
> <message-type>ERROR</message-type> 
> </task-result-details> 
> </frmwk-task-result-details> 
> </frmwk-task-result> 
> <component-task-result
> xmlns="http://java.sun.com/xml/ns/jbi/management-message"> 
>         <component-name>servicemix-http</component-name> 
>         <component-task-result-details> 
>                 <task-result-details> 
>                         <task-id>deploy</task-id> 
>                         <task-result>FAILED</task-result> 
>                         <message-type>ERROR</message-type> 
>                         <task-status-msg> 
> <msg-loc-info> 
> <loc-token/> 
> <loc-message>Unable to find suitable deployer for Service Unit
> 'BpelService-HTTP'</loc-message> 
> </msg-loc-info> 
> </task-status-msg> 
>                 </task-result-details> 
>         </component-task-result-details> 
> </component-task-result> 
> <component-task-result> 
> <component-name>OdeBpelEngine</component-name> 
> <component-task-result-details> 
> <task-result-details> 
> <task-id>deploy</task-id> 
> <task-result>SUCCESS</task-result> 
> <message-type>WARNING</message-type> 
> <task-status-msg> 
> <msg-loc-info> 
> <loc-token/> 
> <loc-message>Unable to parse result string</loc-message> 
> </msg-loc-info> 
> </task-status-msg> 
> <exception-info> 
> <nesting-level>1</nesting-level> 
> <loc-token/> 
> <loc-message/> 
> <stack-trace><![CDATA[java.lang.NullPointerException 
>         at
> org.apache.servicemix.jbi.framework.DeploymentService.getChildElement(DeploymentService.j

> ava:648) 
>         at
> org.apache.servicemix.jbi.framework.DeploymentService.getComponentTaskResult(DeploymentSe

> rvice.java:600) 
>         at
> org.apache.servicemix.jbi.framework.DeploymentService.deployServiceAssembly(DeploymentSer

> vice.java:528) 
>         at
> org.apache.servicemix.jbi.framework.AutoDeploymentService.updateArchive(AutoDeploymentSer

> vice.java:335) 
>         at
> org.apache.servicemix.jbi.framework.AutoDeploymentService.monitorDirectory(AutoDeployment

> Service.java:646) 
>         at
> org.apache.servicemix.jbi.framework.AutoDeploymentService.access$200(AutoDeploymentServic

> e.java:62) 
>         at
> org.apache.servicemix.jbi.framework.AutoDeploymentService$1.run(AutoDeploymentService.jav

> a:609) 
>         at java.util.TimerThread.mainLoop(Timer.java:512) 
>         at java.util.TimerThread.run(Timer.java:462) 
> ]]></stack-trace> 
> </exception-info> 
> </task-result-details> 
> </component-task-result-details> 
> </component-task-result> 
> </jbi-task-result> 
> </jbi-task> 
> 
> 
> the deploy.xml of Bpel process looks like this, 
> <deploy xmlns="http://www.apache.org/ode/schemas/dd/2007/03" 
>         xmlns:pns="http://BpelService" 
>         xmlns:bs="http://www.example.org/BpelService/" 
>         xmlns:ss="http://www.example.org/SimpleService/"> 
> 
>         <process name="pns:BpelService"> 
>                 <active>true</active> 
>                 <provide partnerLink="ConsumerBpelService"> 
>                         <service name="bs:BpelService"
> port="BpelServiceSOAP"/> 
>                 </provide> 
>                 <invoke partnerLink="ProviderSimpleService"> 
>                         <service name="ss:SimpleService"
> port="SimpleServiceSOAP"/> 
>                 </invoke> 
>         </process> 
>     
> </deploy> 
> Can anyone help me out in figuring out the issue. 
> 
> Thank you. 
> 
> 

-- 
View this message in context: http://www.nabble.com/problem-in-delpoying-BPEL-service-unit-on-ODE-JBI%2C-servicemix-tp16088774p16092374.html
Sent from the Apache Ode User mailing list archive at Nabble.com.


Mime
View raw message