ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Łukasz Budnik" <lukasz.bud...@gmail.com>
Subject Re: deploy.xml - Cannot find definition for service error [Solution]
Date Sat, 26 Jan 2008 09:59:00 GMT
Hi All!

The solution is quite simple.

Eclipse BPEL Designer can generate {process_name}Artifacts.wsdl from
provided URL and
generate something like this:

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<definitions xmlns:plnk="http://docs.oasis-open.org/wsbpel/2.0/plnktype"
	xmlns:tns="http://bpel.ode.sandbox.nuntius.xh.orgArtifacts"
	xmlns:vprop="http://docs.oasis-open.org/wsbpel/2.0/varprop"
	xmlns:wsdl="http://ws.tomcat.sandbox.nuntius.xh.org"
	name="OdeTest2Artifacts"
	targetNamespace="http://bpel.ode.sandbox.nuntius.xh.orgArtifacts"
	xmlns="http://schemas.xmlsoap.org/wsdl/">
	<plnk:partnerLinkType name="TimerPartnerLinkType">
		<plnk:role name="TimerProvider"
			portType="wsdl:TimerServicePortType" />
	</plnk:partnerLinkType>
	<import
		location="http://localhost:8080/axis2/services/TimerService?wsdl"
		namespace="http://ws.tomcat.sandbox.nuntius.xh.org" />
</definitions>

note the location attribute pointing to:
http://localhost:8080/axis2/services/TimerService?wsdl

This won't work in Ode. You must to download the TimerService.wsdl and
place it in the same folder as Your BPEL and change location attribute
to simply "TimerService.wsdl".

Then it works.

best regards
Łukasz
Mime
View raw message