ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tammo van Lessen <tvanles...@gmail.com>
Subject Re: deployment of bpel process failed
Date Fri, 04 Jan 2008 13:00:11 GMT
Hi,

the service to be called must be declared using the <invoke> element in
your deploy.xml (instead of <provide>)

Hope this helps,
  Tammo

[1] http://ode.apache.org/user-guide.html#UserGuide-DeploymentDescriptor

henry human wrote:
> Hi
> I have a bpel process with own wsdl (wsdl 1) and
> another wsdl (wsdl 2)  for the second service which
> will be called by the bepl process.
> In the deploy file I declare both services. 
> I see in the log message that ode create the service
> than try to register and than do unegister and finally
> destroy it!
> I do not understand where is the mistake in my deploy
> file. Ode say in his error:
> Deployment failed within the engine.
> Thanks for your hint 
> 
>   
> 
> ---------------  wsdl
> 1---------------------------------
> <?xml version="1.0" encoding="UTF-8"?>
> <definitions name="supplyProcess" 
>    
> targetNamespace="http://co.ts.com/wsdl/supplyProcess"
>     xmlns="http://schemas.xmlsoap.org/wsdl/"
>     xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
>     xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
>     xmlns:xsd="http://www.w3.org/2001/XMLSchema" 
>     xmlns:tns="http://co.ts.com/wsdl/supplyProcess" 
>     xmlns:ns="http://co.ts.com/schema/supplyProcess" 
>    
> xmlns:plink="http://schemas.xmlsoap.org/ws/2004/03/partner-link/">
>     <types>
>     
>     
> ---------------  wsdl 2-------------------
>     <?xml version="1.0" encoding="UTF-8"?>
> <wsdl:definitions targetNamespace=
> "http://co.ts.ms.com/service" 
>                   xmlns:tns=      
> "http://co.ts.ms.com/service"
>                   xmlns:att=    
> "http://co.ts.ms.com/att" 
>                   xmlns:xsd=      
> "http://www.w3.org/2001/XMLSchema" 
>                   xmlns:soap=     
> "http://schemas.xmlsoap.org/wsdl/soap/" 
>                   xmlns:wsdl=     
> "http://schemas.xmlsoap.org/wsdl/" 
>                   xmlns:plnk=     
> "http://schemas.xmlsoap.org/ws/2004/03/partner-link/" 
>                   xmlns=          
> "http://schemas.xmlsoap.org/wsdl/">
>     <wsdl:documentation>
>     
>   --------------- bpel-------------------
>    <process 
>     name="supplyProcess" 
>    
> targetNamespace="http://co.ts.com/bpel/supplyProcess"
>     xmlns=         
> "http://schemas.xmlsoap.org/ws/2004/03/business-process/"
>     xmlns:bkk=    
> "http://schemas.xmlsoap.org/ws/2004/03/business-process/"
>     xmlns:ns1=     
> "http://co.ts.com/wsdl/supplyProcess" 
>     xmlns:n0=      
> "http://co.ts.com/schema/supplyProcess" 
>     xmlns:ns2=      "http://co.ts.ms.com/service"
>     xmlns:ns3=      "http://co.ts.ms.com/att"
>     xmlns:ns4=      "http://top.co.ts.com/simpleAtt"
>     xmlns:ns5=     
> "http://www.w3.org/2001/XMLSchema">
>     
> ----------------- deploy.xml-------------------
>    <deploy
> xmlns="http://www.apache.org/ode/schemas/dd/2007/03" 
> 	xmlns:pns="http://co.ts.com/bpel/supplyProcess"
> xmlns:wns="http://co.ts.com/wsdl/supplyProcess" 
> 	xmlns:top="http://co.ts.ms.com/service">
> 	<process name="pns:supplyProcess">
> 		<active>true</active>
> 		<provide partnerLink="supplyBpelPartnerLink">
> 			<service name="wns:co.ts.ms.comProcessService"
> port="supplyProcessPort"/>
> 	        </provide>
> 	        
> 	        <provide partnerLink="topSupplyPartnerLink">
> 			<service name="top:topCnwService"
> port="topCnwService"/>
> 	        </provide>
> 	      
> 	        
> 	        		
> 	</process>
> </deploy> 
>    
>    
>    
>     
> ---------------- error from ODE  -------------------
>    
> INFO - GeronimoLog.info(79) | Process
> {http://co.ts.com/bpel/supplyBpelProcess}supplyProcess-18
> has been unregistered.
> 12:59:24,096 INFO  [BpelServerImpl] Process
> {http://co.ts.com/bpel/supplyProcess}supplyProcess-18
> has been unregistered.
> ERROR - GeronimoLog.error(108) | Deployment of
> supplyProcess failed, aborting
>  for now.
> org.apache.ode.bpel.iapi.ContextException: Deployment
> failed within the engine.
>         at
> org.apache.ode.store.ProcessStoreImpl.deploy(ProcessStoreImpl.java:29
> 1)
>         at
> org.apache.ode.axis2.deploy.DeploymentPoller.check(DeploymentPoller.j
> ava:144)
>         at
> org.apache.ode.axis2.deploy.DeploymentPoller.access$300(DeploymentPol
> ler.java:55)
>         at
> org.apache.ode.axis2.deploy.DeploymentPoller$PollingThread.run(Deploy
> mentPoller.java:188)
> Caused by: java.lang.NullPointerException
>         at
> org.apache.ode.axis2.BindingContextImpl.createPartnerRoleChannel(Bind
> ingContextImpl.java:76)
>         at
> org.apache.ode.bpel.engine.BpelProcess$HydrationLatch.doHydrate(BpelP
> rocess.java:711)
>         at
> org.apache.ode.bpel.engine.BpelProcess$HydrationLatch.access$100(Bpel
> Process.java:654)
>         at
> org.apache.ode.bpel.engine.BpelProcess$HydrationLatch$2.run(BpelProce
> ss.java:666)
>         at
> org.apache.ode.bpel.engine.NStateLatch.latch(NStateLatch.java:89)
>         at
> org.apache.ode.bpel.engine.BpelProcess.hydrate(BpelProcess.java:547)
>         at
> org.apache.ode.bpel.engine.BpelServerImpl.register(BpelServerImpl.jav
> a:277)
>         at
> org.apache.ode.axis2.ODEServer.handleEvent(ODEServer.java:526)
>         at
> org.apache.ode.axis2.ODEServer.access$100(ODEServer.java:70)
>         at
> org.apache.ode.axis2.ODEServer$ProcessStoreListenerImpl.onProcessStor
> eEvent(ODEServer.java:512)
>         at
> org.apache.ode.store.ProcessStoreImpl.fireEvent(ProcessStoreImpl.java
> :501)
>         at
> org.apache.ode.store.ProcessStoreImpl.fireStateChange(ProcessStoreImp
> l.java:507)
>         at
> org.apache.ode.store.ProcessStoreImpl.deploy(ProcessStoreImpl.java:28
> 4)
>         ... 3 more
> 12:59:24,106 ERROR [DeploymentPoller] Deployment of
> SupplyProcess failed, abo
> rting for now.
> org.apache.ode.bpel.iapi.ContextException: Deployment
> failed within the engine.
>         at
> org.apache.ode.store.ProcessStoreImpl.deploy(ProcessStoreImpl.java:29
> 1)
>         at
> org.apache.ode.axis2.deploy.DeploymentPoller.check(DeploymentPoller.j
> ava:144)
>         at
> org.apache.ode.axis2.deploy.DeploymentPoller.access$300(DeploymentPol
> ler.java:55)
>         at
> org.apache.ode.axis2.deploy.DeploymentPoller$PollingThread.run(Deploy
> mentPoller.java:188)
> Caused by: java.lang.NullPointerException
>         at
> org.apache.ode.axis2.BindingContextImpl.createPartnerRoleChannel(Bind
> ingContextImpl.java:76)
>         at
> org.apache.ode.bpel.engine.BpelProcess$HydrationLatch.doHydrate(BpelP
> rocess.java:711)
>         at
> org.apache.ode.bpel.engine.BpelProcess$HydrationLatch.access$100(Bpel
> Process.java:654)
>         at
> org.apache.ode.bpel.engine.BpelProcess$HydrationLatch$2.run(BpelProce
> ss.java:666)
>         at
> org.apache.ode.bpel.engine.NStateLatch.latch(NStateLatch.java:89)
>         at
> org.apache.ode.bpel.engine.BpelProcess.hydrate(BpelProcess.java:547)
>         at
> org.apache.ode.bpel.engine.BpelServerImpl.register(BpelServerImpl.jav
> a:277)
>         at
> org.apache.ode.axis2.ODEServer.handleEvent(ODEServer.java:526)
>         at
> org.apache.ode.axis2.ODEServer.access$100(ODEServer.java:70)
>         at
> org.apache.ode.axis2.ODEServer$ProcessStoreListenerImpl.onProcessStor
> eEvent(ODEServer.java:512)
>         at
> org.apache.ode.store.ProcessStoreImpl.fireEvent(ProcessStoreImpl.java
> :501)
>         at
> org.apache.ode.store.ProcessStoreImpl.fireStateChange(ProcessStoreImp
> l.java:507)
>         at
> org.apache.ode.store.ProcessStoreImpl.deploy(ProcessStoreImpl.java:28
> 4)
>         ... 3 more
> 
> 
>        __________________________________  Ihre erste Baustelle? Wissenswertes für Bastler
und Hobby Handwerker. www.yahoo.de/clever


Mime
View raw message