ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthieu Riou" <matth...@offthelip.org>
Subject Re: NullPointerException at process deployment
Date Mon, 03 Dec 2007 15:15:01 GMT
Hi Sebastien,

Your problem is probably that ports aren't qualified names, just local
names. In your deploy.xml you've set a namespace prefix for the two ports
that get invoked. I'll had a little check so that next time, a more explicit
exception gets thrown.

Cheers,
Matthieu

On Dec 3, 2007 6:05 AM, S?ebastien Mosser <mosser@polytech.unice.fr> wrote:

> Dear everybody.
>
> I'm a "newbe" in ODE World, but I've got a serious problem trying to
> deploy a BPEL process in ODE (typically a Null pointer exception !).
>
>
> I wrote a simple process using Eclipse BPEL Designer, providing one
> service and invoking two others.
>
> My process is described in BPEL in GetConvertedValue.bpel, and WSDL
> interface can be found in GetConvertedValue.wsdl. Eclipse generate a new
> WSDL file dealing with process artefacts, auto-generated.
>
> This process 'try' to invoke two partners :
>   - Stock (StockService.wsdl)
>   - Convert (ConvertService.wsdl)
>
> I know that I have to bind each partnerLink to endpoints in my
> deploy.xml descriptor. So, I wrote such binding in 'deploy.xml'.
>
> When I try to deploy the directory in my ODE installation (which is
> supposed to work using the 'counter' tutorial), basically copying my
> directory into '/opt/jetty-6.1.6/webapps/ode/WEB-INF/processes', I
> encounter the following error :
>
> > ERROR - GeronimoLog.error(108) | Deployment of GetConvertedStockValue
> failed, aborting for now.
> > org.apache.ode.bpel.iapi.ContextException: Deployment failed within the
> engine.
> >         at org.apache.ode.store.ProcessStoreImpl.deploy(
> ProcessStoreImpl.java:291)
> >         at org.apache.ode.axis2.deploy.DeploymentPoller.check(
> DeploymentPoller.java:144)
> >         at org.apache.ode.axis2.deploy.DeploymentPoller.access$300(
> DeploymentPoller.java:55)
> >         at
> org.apache.ode.axis2.deploy.DeploymentPoller$PollingThread.run(
> DeploymentPoller.java:188)
> > Caused by: java.lang.NullPointerException
> >         at org.apache.ode.axis2.hooks.ODEAxisService.extractServiceName(
> ODEAxisService.java:128)
> >         at org.apache.ode.axis2.hooks.ODEAxisService.createService(
> ODEAxisService.java:60)
> >         at org.apache.ode.axis2.ODEServer.createService(ODEServer.java
> :299)
> >         at
> org.apache.ode.axis2.BindingContextImpl.activateMyRoleEndpoint(
> BindingContextImpl.java:59)
> >         at org.apache.ode.bpel.engine.BpelProcess.activate(
> BpelProcess.java:442)
> >         at org.apache.ode.bpel.engine.BpelEngineImpl.registerProcess(
> BpelEngineImpl.java:221)
> >         at org.apache.ode.bpel.engine.BpelServerImpl.register(
> BpelServerImpl.java:275)
> >         at org.apache.ode.axis2.ODEServer.handleEvent(ODEServer.java
> :526)
> >         at org.apache.ode.axis2.ODEServer.access$100(ODEServer.java:70)
> >         at
> org.apache.ode.axis2.ODEServer$ProcessStoreListenerImpl.onProcessStoreEvent
> (ODEServer.java:512)
> >         at org.apache.ode.store.ProcessStoreImpl.fireEvent(
> ProcessStoreImpl.java:501)
> >         at org.apache.ode.store.ProcessStoreImpl.fireStateChange(
> ProcessStoreImpl.java:507)
> >         at org.apache.ode.store.ProcessStoreImpl.deploy(
> ProcessStoreImpl.java:284)
> >         ... 3 more
>
> After a quick search inside this mailing list archive, It seems to be a
> deploy.xml trouble ... but I think I miss a point inside it !
>
> Thanks by advance.
>
> --
>  Sebastien Mosser
>  EPU Polytech'Nice - Sophia Antipolis, Bureau 314
>  CNRS / I3S / Rainbow - http://rainbow.i3s.unice.fr/~mosser<http://rainbow.i3s.unice.fr/%7Emosser>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message